summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2018-02-11 15:25:47 +0100
committerLucas Werkmeister2018-02-11 15:25:47 +0100
commite61a57838469cecb264738487eded05b64001bfa (patch)
tree943492720eaaaa32a4b914ddfc1a396bb2969110
parentddb064a47e91fbf1fb82c532e55169d2c603d590 (diff)
downloadaur-e61a57838469cecb264738487eded05b64001bfa.tar.gz
Update for mkosi v4
This adds several optional dependencies, though I’m not sure if all of them are correct, especially around the QEMU area. I have verified that GitHub’s tarball contains the same tree as the v3 tag in my clone: $ rm -f v4.tar.gz $ wget -q https://github.com/systemd/mkosi/archive/v4.tar.gz $ gunzip < v4.tar.gz | sha256sum c1e12afe7f8a7e54aafe564ecc0439ef8c8b9800879d8181c1ac7e8f399bad19 - $ git archive v4 --prefix=mkosi-4/ | sha256sum c1e12afe7f8a7e54aafe564ecc0439ef8c8b9800879d8181c1ac7e8f399bad19 - $ sha256sum v4.tar.gz # this is the sha256sum in the PKGBUILD file 855666aa7a16fcc41b0a2e5f12dc1916d19e03c9d174332ef0fd53cb137da8f2 v4.tar.gz I have also verified that the v4 tag in my clone was signed (validly) by the same key [1] that also signed the v232 and v237 tags in my clone of the systemd repository. Since I do not have any web-of-trust connection to Lennart Poettering, that will have to do. [1]: Primary key fingerprint: 63CD A1E5 D3FC 22B9 98D2 0DD6 327F 2695 1A01 5CC4 Subkey fingerprint: 16B1 C4EE C0BC 021A C777 F681 B63B 2187 9C34 85B0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dc3070bbd91..dbb473de5d7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Jun 28 22:23:35 UTC 2017
+# Sun Feb 11 14:25:44 UTC 2018
pkgbase = mkosi
pkgdesc = Build Legacy-Free OS Images
- pkgver = 3
+ pkgver = 4
pkgrel = 1
url = https://github.com/systemd/mkosi
arch = any
license = LGPL2.1
makedepends = python-setuptools
depends = python
- optdepends = dnf: build Fedora images
+ optdepends = dnf: build Fedora or Mageia images
optdepends = debootstrap: build Debian or Ubuntu images
+ optdepends = debian-archive-keyring: build Debian images
+ optdepends = ubuntu-keyring: build Ubuntu images
optdepends = arch-install-scripts: build Arch images
optdepends = zypper-git: build openSUSE images
optdepends = gnupg: sign images
@@ -21,9 +23,11 @@ pkgbase = mkosi
optdepends = tar: tar output format
optdepends = cryptsetup: add dm-verity partitions
optdepends = edk2-ovmf: run bootable images in QEMU
+ optdepends = qemu: run bootable images in QEMU
+ optdepends = qemu-kvm: run bootable images in QEMU
optdepends = sbsigntools: sign EFI binaries for UEFI SecureBoot
- source = https://github.com/systemd/mkosi/archive/v3.tar.gz
- sha256sums = 3bb606f16a26e08ce071e673cb935e62cecb3559db6b41c620f240666d7c5734
+ source = https://github.com/systemd/mkosi/archive/v4.tar.gz
+ sha256sums = 855666aa7a16fcc41b0a2e5f12dc1916d19e03c9d174332ef0fd53cb137da8f2
pkgname = mkosi
diff --git a/PKGBUILD b/PKGBUILD
index cfb8cc6c9597..74856cd54ee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dave Reisner <dreisner@archlinux.org>
pkgname=mkosi
-pkgver=3
+pkgver=4
pkgrel=1
pkgdesc='Build Legacy-Free OS Images'
arch=('any')
@@ -10,8 +10,10 @@ url='https://github.com/systemd/mkosi'
license=('LGPL2.1')
depends=('python')
makedepends=('python-setuptools')
-optdepends=('dnf: build Fedora images'
+optdepends=('dnf: build Fedora or Mageia images'
'debootstrap: build Debian or Ubuntu images'
+ 'debian-archive-keyring: build Debian images'
+ 'ubuntu-keyring: build Ubuntu images'
'arch-install-scripts: build Arch images'
'zypper-git: build openSUSE images'
'gnupg: sign images'
@@ -22,9 +24,11 @@ optdepends=('dnf: build Fedora images'
'tar: tar output format'
'cryptsetup: add dm-verity partitions'
'edk2-ovmf: run bootable images in QEMU'
+ 'qemu: run bootable images in QEMU'
+ 'qemu-kvm: run bootable images in QEMU'
'sbsigntools: sign EFI binaries for UEFI SecureBoot')
source=("https://github.com/systemd/mkosi/archive/v$pkgver.tar.gz")
-sha256sums=('3bb606f16a26e08ce071e673cb935e62cecb3559db6b41c620f240666d7c5734')
+sha256sums=('855666aa7a16fcc41b0a2e5f12dc1916d19e03c9d174332ef0fd53cb137da8f2')
package() {
cd "mkosi-$pkgver"