summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2023-07-07 19:59:38 +0200
committerLucas Werkmeister2023-07-07 19:59:38 +0200
commit6bba67f76a0fc3868fc5b33fa55068c867040492 (patch)
tree90d6a8d39911c2d07c4435b92429e4356a947ebf
parent173d1ae991dfb54d74ec47c9cffa77113151b4be (diff)
downloadaur-6bba67f76a0fc3868fc5b33fa55068c867040492.tar.gz
Update build process and add pandoc to makedepends
Since the setup.py build process is deprecated, switch to the standards-based one [1] – seems to work like a charm. Since the new build includes a pandoc step and fails if pandoc isn’t available, add that to the makedepends. Everyone who wants to use this package will just have to live with the massive package list, disk space usage, and slew of upgrades that installing pandoc brings with it. [1]: https://wiki.archlinux.org/index.php?title=Python_package_guidelines&oldid=781620#Standards_based_(PEP_517)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a81877db9211..7034a52bc932 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = mkosi-git
pkgdesc = Build Legacy-Free OS Images
- pkgver = 14.r348.g4c2037ca89
+ pkgver = 14.r762.g3633102500
pkgrel = 1
url = https://github.com/systemd/mkosi
arch = any
license = LGPL2.1
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = pandoc
makedepends = git
depends = python
depends = bubblewrap
diff --git a/PKGBUILD b/PKGBUILD
index 8c6a96566a20..199a7c669991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Reto Brunner <brunnre8@gmail.com>
pkgname=mkosi-git
-pkgver=14.r348.g4c2037ca89
+pkgver=14.r762.g3633102500
pkgrel=1
pkgdesc='Build Legacy-Free OS Images'
arch=('any')
@@ -11,7 +11,10 @@ url='https://github.com/systemd/mkosi'
license=('LGPL2.1')
depends=('python'
'bubblewrap')
-makedepends=('python-setuptools'
+makedepends=('python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'pandoc'
'git')
optdepends=('dnf: build Fedora or Mageia images'
'apt: build Debian or Ubuntu images'
@@ -60,13 +63,13 @@ pkgver() {
build() {
cd 'mkosi'
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd 'mkosi'
- python setup.py install --skip-build --optimize=1 --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 man/mkosi.1 "$pkgdir/usr/share/man/man1/mkosi.1" || true
}