summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2021-11-24 20:05:45 +0100
committerLucas Werkmeister2021-11-24 20:05:45 +0100
commita43d06b9692e481579612e319c6b65e24feea34b (patch)
treeab164b8967f0745bb27afb0a137255ef8d3f2721
parent912fe030a978c3161aa50a3961de8d470bd6c183 (diff)
downloadaur-a43d06b9692e481579612e319c6b65e24feea34b.tar.gz
Remove pandoc makedepends and refresh pkgver (v11)
mkosi includes the built man page in the repo nowadays.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 4 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc971e3e2e09..0b5282c52d66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = mkosi-git
pkgdesc = Build Legacy-Free OS Images
- pkgver = 10.r0.g4d64fc8
+ pkgver = 11.r1.gf7d518e
pkgrel = 1
url = https://github.com/systemd/mkosi
arch = any
license = LGPL2.1
makedepends = python-setuptools
makedepends = git
- makedepends = pandoc
depends = python
optdepends = dnf: build Fedora or Mageia images
optdepends = debootstrap: build Debian or Ubuntu images
diff --git a/PKGBUILD b/PKGBUILD
index e59a8007dcd5..c3c7c089d2ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Reto Brunner <brunnre8@gmail.com>
pkgname=mkosi-git
-pkgver=10.r0.g4d64fc8
+pkgver=11.r1.gf7d518e
pkgrel=1
pkgdesc='Build Legacy-Free OS Images'
arch=('any')
@@ -11,9 +11,7 @@ url='https://github.com/systemd/mkosi'
license=('LGPL2.1')
depends=('python')
makedepends=('python-setuptools'
- 'git'
- # pandoc is optional-ish – if missing, the package still builds
- 'pandoc')
+ 'git')
optdepends=('dnf: build Fedora or Mageia images'
'debootstrap: build Debian or Ubuntu images'
'debian-archive-keyring: build Debian images'
@@ -58,12 +56,6 @@ build() {
cd 'mkosi'
python setup.py build
-
- # try to build the manpage but tolerate “command not found” (but not other errors)
- pandoc -s -f markdown -t man mkosi.md -o mkosi.1 || error=$?
- if ((error != 0 && error != 127)); then
- return $error
- fi
}
package() {
@@ -71,7 +63,5 @@ package() {
python setup.py install --skip-build --optimize=1 --root="$pkgdir"
- # as in build(), try to install the manpage but tolerate “file not found”
- # (but in this case there’s no specific error code to check)
- install -Dm 644 mkosi.1 "$pkgdir/usr/share/man/man1/mkosi.1" || true
+ install -Dm 644 man/mkosi.1 "$pkgdir/usr/share/man/man1/mkosi.1" || true
}