summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReto Brunner2019-01-10 19:48:07 +0100
committerLucas Werkmeister2019-01-10 22:36:00 +0100
commitc6fc4fe3ee0d7101c35d9eb02026ad2ce5def227 (patch)
treeec49f607d139be00483cd623401e4f59fd4240fb
parentd83b6d5712c94e27958ffc139b999e6913c87982 (diff)
downloadaur-c6fc4fe3ee0d7101c35d9eb02026ad2ce5def227.tar.gz
Split off build step
Move the build part of setup.py into the build function, where it belongs. This brings the package closer to the guidelines [1]. [1]: https://wiki.archlinux.org/index.php/Python_package_guidelines#distutils
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db1d79f56d15..00c94fde3be6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
# Contributor: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Reto Brunner <brunnre8@gmail.com>
pkgname=mkosi-git
pkgver=4.r85.g2fcdbfa
@@ -50,8 +51,14 @@ pkgver() {
'
}
+build() {
+ cd 'mkosi'
+
+ python setup.py build
+}
+
package() {
cd 'mkosi'
- python setup.py install --root="$pkgdir"
+ python setup.py install --skip-build --root="$pkgdir"
}