summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Brost2017-08-10 00:54:01 +0200
committerJulian Brost2017-08-10 00:54:01 +0200
commitf75160537cfd8088b171aa65ddec5aa75a7112c8 (patch)
tree7094d94893ec813ecf72ebb37b8f88433ce65964
downloadaur-f75160537cfd8088b171aa65ddec5aa75a7112c8.tar.gz
release version 5.2.17-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD25
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54ad615b408e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Aug 9 22:53:52 UTC 2017
+pkgbase = mkpasswd
+ pkgdesc = Tool for creating password hashes suitable for /etc/shadow
+ pkgver = 5.2.17
+ pkgrel = 1
+ url = https://github.com/rfc1036/whois
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = perl
+ depends = glibc
+ source = whois-5.2.17.tar.gz::https://github.com/rfc1036/whois/archive/v5.2.17.tar.gz
+ sha256sums = c3c47b139bafc4348d6794a0cca311e3adfb4aae0597f1279faa73b749ecf0d2
+
+pkgname = mkpasswd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e0c654fac7b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/*.log
+*.swp
+/*.tar
+/*.tar.gz
+/*.tar.xz
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51215d40aef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Julian Brost <julian@0x4a42.net>
+
+pkgname=mkpasswd
+pkgver=5.2.17
+pkgrel=1
+pkgdesc="Tool for creating password hashes suitable for /etc/shadow"
+arch=('i686' 'x86_64')
+url="https://github.com/rfc1036/whois"
+license=('GPL')
+depends=('glibc')
+makedepends=('perl')
+source=("whois-$pkgver.tar.gz::https://github.com/rfc1036/whois/archive/v5.2.17.tar.gz")
+sha256sums=('c3c47b139bafc4348d6794a0cca311e3adfb4aae0597f1279faa73b749ecf0d2')
+
+build() {
+ cd "${srcdir}/whois-${pkgver}"
+
+ make prefix=/usr CFLAGS="$CFLAGS $CPPFLAGS"
+}
+
+package() {
+ cd "${srcdir}/whois-${pkgver}"
+
+ make prefix=/usr BASEDIR="${pkgdir}" install-mkpasswd
+}