summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Chapuis2016-06-13 21:55:01 +0200
committerPierre Chapuis2016-06-13 21:55:01 +0200
commite896c47cfc42eb9929a5ba8021c4e561dc55e2d8 (patch)
tree20b9dc96f23bbc6a1ab63e9c472c2689b1713413
downloadaur-e896c47cfc42eb9929a5ba8021c4e561dc55e2d8.tar.gz
initial commit - v0.5.6
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1943bf066598
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mksend
+ pkgdesc = Tool to redirect, modify and send frames from a traffic active link.
+ pkgver = 0.5.6
+ pkgrel = 3
+ url = https://bitbucket.org/radare/mksend
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mercurial
+ depends = libpcap
+
+pkgname = mksend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84f88ab32ca9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: catwell <catwell@archlinux.us>
+
+pkgname=mksend
+pkgver=0.5.6
+pkgrel=3
+pkgdesc="Tool to redirect, modify and send frames from a traffic active link."
+arch=(i686 x86_64)
+url="https://bitbucket.org/radare/mksend"
+license=(GPL)
+depends=(libpcap)
+makedepends=(mercurial)
+source=()
+
+_hgroot="https://bitbucket.org/radare"
+_hgrepo=mksend
+_hgrev="14984eb"
+
+build() {
+ cd "$srcdir"
+ rm -rf "$_hgrepo"
+ hg clone "$_hgroot/$_hgrepo" -r "$_hgrev"
+ cd "$_hgrepo"
+ chmod +x configure
+ export LDFLAGS="${LDFLAGS//,--as-needed}"
+ export CFLAGS="${CFLAGS} -std=gnu89"
+ export CPPFLAGS=
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_hgrepo"
+ install -d "$pkgdir/usr/share/mksend/db" "$pkgdir/usr/share/mksend/scripts"
+ install -m0644 db/*.xml "$pkgdir/usr/share/mksend/db/"
+ install -m0755 scripts/*.sh "$pkgdir/usr/share/mksend/scripts/"
+ install -Ds src/mksend "$pkgdir/usr/bin/mksend"
+ install -Ds pcaptool/pcaptool "$pkgdir/usr/bin/pcaptool"
+ install -Dm0444 doc/man/man1/pcaptool.1 \
+ "$pkgdir/usr/share/man/man1/pcaptool.1"
+}