summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-04-12 18:59:36 +0200
committersL1pKn072018-04-12 18:59:36 +0200
commita0862e3e9efc3714c97f741acf133933b973278e (patch)
treee0c467698e9c37a21031e6b03312e51065d3a5f5
parent33c5b7d1e8e113123d0f24bc56f3bacc3eebe2c5 (diff)
downloadaur-a0862e3e9efc3714c97f741acf133933b973278e.tar.gz
drop non x86_64 architectures (follow archlinux flow). if you need, you can feel to free upload a new package with differen architecture support. sorry and greetings
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 5 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db7159b2d6fb..c25060a36d0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
# Generated by mksrcinfo v8
-# Sun Sep 17 18:01:41 UTC 2017
+# Thu Apr 12 16:59:17 UTC 2018
pkgbase = mkvalidator
pkgdesc = Validator for MKV files
pkgver = 0.5.2
pkgrel = 1
url = http://www.matroska.org/downloads/mkvalidator.html
- arch = armv6h
- arch = i686
arch = x86_64
license = BSD
options = !makeflags
diff --git a/PKGBUILD b/PKGBUILD
index 1cf0f9199e58..f5ba642ce877 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=mkvalidator
pkgver=0.5.2
pkgrel=1
pkgdesc="Validator for MKV files"
-arch=('armv6h' 'i686' 'x86_64')
+arch=('x86_64')
url='http://www.matroska.org/downloads/mkvalidator.html'
license=('BSD')
source=("http://sourceforge.net/projects/matroska/files/mkvalidator/mkvalidator-${pkgver}.tar.bz2")
@@ -17,27 +17,16 @@ prepare() {
gcc ${CFAGS} -o coremake corec/tools/coremake/coremake.c
- if [ "${CARCH}" = "i686" ]; then
- _target="gcc_linux"
- elif [ "${CARCH}" = "x86_64" ]; then
- _target="gcc_linux_x64"
- elif [ "${CARCH}" = "armv6h" ]; then
- sed 's|arm-linux-gnueabi-||g' -i corec/tools/coremake/gcc_linux_arm
- _target="gcc_linux_arm"
- fi
-
sed "s|/usr/local|${pkgdir}/usr|g" -i corec/tools/coremake/gcc_mak.inc
- ./coremake ${_target}
+ ./coremake gcc_linux_x64
}
build(){
- cd "mkvalidator-${pkgver}/mkvalidator"
- make
+ make -C "mkvalidator-${pkgver}/mkvalidator"
}
package(){
- cd "mkvalidator-${pkgver}/mkvalidator"
mkdir -p "${pkgdir}/usr/bin"
- make install
+ make -C "mkvalidator-${pkgver}/mkvalidator" install
}