summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodolphe Bréard2021-02-27 11:35:20 +0100
committerRodolphe Bréard2021-02-27 11:35:20 +0100
commitf855408aa438a71f2a162f7c8196ffe9ef33b0e5 (patch)
tree824d13afc6414a2704794532941194a9e7837054
downloadaur-f855408aa438a71f2a162f7c8196ffe9ef33b0e5.tar.gz
mlar 1.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD23
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..344f185f0d52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mlar
+ pkgdesc = A pure rust encrypted and compressed archive file utility
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/ANSSI-FR/MLA
+ arch = x86_64
+ license = LGPL3
+ makedepends = rust
+ makedepends = cargo
+ depends = gcc-libs
+ source = mlar-1.1.0.tar.gz::https://github.com/ANSSI-FR/MLA/archive/mla-v1.1.0.tar.gz
+ sha256sums = b8f2a3b7595e491cf4f6d6e3886cd94af0a9a8b16f576dc901337fefaf048c8c
+
+pkgname = mlar
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d2dbfc3849f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*.tar.xz
+*.tar.gz
+*.tar.zst
+**/*.rs.bk
+*~
+\#*
+.\#*
+*.swp
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbfad1d97572
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Rodolphe Bréard <packages@what.tf>
+pkgname=mlar
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A pure rust encrypted and compressed archive file utility"
+arch=('x86_64')
+url="https://github.com/ANSSI-FR/MLA"
+license=('LGPL3')
+depends=('gcc-libs')
+makedepends=('rust' 'cargo')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ANSSI-FR/MLA/archive/mla-v$pkgver.tar.gz")
+sha256sums=('b8f2a3b7595e491cf4f6d6e3886cd94af0a9a8b16f576dc901337fefaf048c8c')
+
+build() {
+ cd "MLA-mla-v$pkgver"
+ cargo update
+ cargo build --release --bin "$pkgname"
+}
+
+package() {
+ cd "MLA-mla-v$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}