summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2019-03-02 13:00:40 +0100
committerBlair Bonnett2019-03-02 13:00:40 +0100
commit884e70ca9df50b713e27a698987a0224f6a35844 (patch)
tree5fff410aa11c692509c42fd28d26f97c88faf197
downloadaur-884e70ca9df50b713e27a698987a0224f6a35844.tar.gz
Initial package of v0.0.10.
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8f7e71a7c8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mlbstreamer
+ pkgdesc = Enables real-time and time-shifted viewing of MLB.tv streams
+ pkgver = 0.0.10
+ pkgrel = 1
+ url = https://github.com/tonycpsu/mlbstreamer
+ arch = any
+ license = GPL2
+ depends = python
+ depends = python-six
+ depends = python-requests
+ depends = python-lxml
+ depends = python-pytz
+ depends = python-tzlocal
+ depends = python-pymemoize
+ depends = python-orderedattrdict
+ depends = python-yaml
+ depends = python-dateutil
+ depends = streamlink>0.11.0
+ depends = python-prompt_toolkit
+ depends = python-urwid
+ depends = python-urwid_utils>=0.1.2
+ depends = python-panwid>0.2.4
+ source = https://github.com/tonycpsu/mlbstreamer/archive/v0.0.10.tar.gz
+ sha256sums = 78550190b990608234241b9ec6a884098b5895da21474eb8b8c7af333a7631ca
+
+pkgname = mlbstreamer
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dbf3fdd9285b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c29be6b14d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
+
+pkgname=mlbstreamer
+pkgver=0.0.10
+pkgrel=1
+pkgdesc="Enables real-time and time-shifted viewing of MLB.tv streams"
+url="https://github.com/tonycpsu/mlbstreamer"
+arch=('any')
+license=('GPL2')
+depends=(
+ 'python' 'python-six' 'python-requests' 'python-lxml' 'python-pytz'
+ 'python-tzlocal' 'python-pymemoize' 'python-orderedattrdict' 'python-yaml'
+ 'python-dateutil' 'streamlink>0.11.0' 'python-prompt_toolkit' 'python-urwid'
+ 'python-urwid_utils>=0.1.2' 'python-panwid>0.2.4'
+)
+source=(
+ "https://github.com/tonycpsu/mlbstreamer/archive/v$pkgver.tar.gz"
+)
+sha256sums=(
+ '78550190b990608234241b9ec6a884098b5895da21474eb8b8c7af333a7631ca'
+)
+
+# The dateutil module is provided through the python-dateutil dependency.
+# However, setuptools doesn't pick this up and so raises a fatal error
+# when the command-line executables start. Removing it from setup.py doesn't
+# affect the build and packaging, but prevents this error.
+prepare() {
+ cd "mlbstreamer-$pkgver"
+ sed -i -e "/py-dateutil/d" setup.py
+}
+
+build() {
+ cd "mlbstreamer-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "mlbstreamer-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ rm -r "$pkgdir/usr/lib/python3.7/site-packages/test"
+}