summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2019-11-19 21:59:33 +0100
committerBlair Bonnett2019-11-19 21:59:33 +0100
commit5633749cc0de9ee3a183acdfe5019b5c0328c1aa (patch)
tree520012031ce40178a31716c06c9a65d33ab391a7
parent7d411a2c96b50a7872caa22b886a58c9cbdb8d58 (diff)
downloadaur-mlbstreamer-git.tar.gz
Fix packaging for Python 3.8.
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c63aeeffc477..da5c61d1b26b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = mlbstreamer-git
pkgdesc = Enables real-time and time-shifted viewing of MLB.tv streams
- pkgver = v0.0.10.r23.g92eb0ad
+ pkgver = v0.0.10.r40.gbb3caab
pkgrel = 1
url = https://github.com/tonycpsu/mlbstreamer
arch = any
license = GPL2
makedepends = git
+ makedepends = python-setuptools
depends = python
depends = python-six
depends = python-requests
@@ -16,11 +17,11 @@ pkgbase = mlbstreamer-git
depends = python-orderedattrdict
depends = python-yaml
depends = python-dateutil
- depends = streamlink>=0.11.0
+ depends = streamlink
depends = python-prompt_toolkit
depends = python-urwid
- depends = python-urwid_utils>=0.1.2
- depends = python-panwid>=0.2.5
+ depends = python-urwid_utils
+ depends = python-panwid
provides = mlbstreamer
conflicts = mlbstreamer
source = git+https://github.com/tonycpsu/mlbstreamer.git
diff --git a/.gitignore b/.gitignore
index a4601bd6f0bd..307dc24ca1eb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ src
pkg
mlbstreamer
*.pkg.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 1df86e6738c8..4e43e952979a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
pkgname=mlbstreamer-git
-pkgver=v0.0.10.r23.g92eb0ad
+pkgver=v0.0.10.r40.gbb3caab
pkgrel=1
pkgdesc="Enables real-time and time-shifted viewing of MLB.tv streams"
url="https://github.com/tonycpsu/mlbstreamer"
@@ -12,10 +12,10 @@ provides=('mlbstreamer')
depends=(
'python' 'python-six' 'python-requests' 'python-lxml' 'python-pytz'
'python-tzlocal' 'python-pymemoize' 'python-orderedattrdict' 'python-yaml'
- 'python-dateutil' 'streamlink>=0.11.0' 'python-prompt_toolkit' 'python-urwid'
- 'python-urwid_utils>=0.1.2' 'python-panwid>=0.2.5'
+ 'python-dateutil' 'streamlink' 'python-prompt_toolkit' 'python-urwid'
+ 'python-urwid_utils' 'python-panwid'
)
-makedepends=('git')
+makedepends=('git' 'python-setuptools')
source=(
'git+https://github.com/tonycpsu/mlbstreamer.git'
)
@@ -47,6 +47,7 @@ build() {
package() {
cd "mlbstreamer"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- rm -r "$pkgdir/usr/lib/python3.7/site-packages/test"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ SPDIR=$(python -c 'import site; print(site.getsitepackages()[0])')
+ rm -r "$pkgdir$SPDIR/test"
}