summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2023-05-25 23:20:36 +0300
committerAdrian Perez de Castro2023-05-25 23:20:36 +0300
commit3e42bdca3c9bf3a18e81967d23e5df6e40794c27 (patch)
treedd36cf9ffc016bf732152657ab54d5487abba852
parentc0853340f664ca07db5acd8b88c846ed2d49519a (diff)
downloadaur-mle.tar.gz
Bump to version 1.7.2
The major change is the switch to pcre2.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eca55fc3c81b..732aa4501f6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = mle
pkgdesc = Flexible terminal-based text editor
- pkgver = 1.5.0
+ pkgver = 1.7.2
pkgrel = 1
url = https://github.com/adsr/mle
arch = x86_64
license = Apache
makedepends = uthash
- depends = pcre
+ depends = pcre2
depends = lua
conflicts = mle-git
- source = https://github.com/adsr/mle/archive/v1.5.0.tar.gz
- sha512sums = b96462dee4212a006a7e93c76954315bb0ead2f28be5e206e3918d9dae2cece6ebf76e6531468f178eb551cd23840ff4c8a77cbedde18808e1c8fd80f25fef49
+ source = https://github.com/adsr/mle/archive/v1.7.2.tar.gz
+ b2sums = a1a29e97245e5604608039b25f8f5c2e9bb27939f795d52d61fa57e679731c06680e75b0fe0dbe80dca511899422d757da0ba73023e2ecf8d937455fa621a78a
pkgname = mle
diff --git a/PKGBUILD b/PKGBUILD
index bb96fe4ac76c..4151a3308079 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Flexible terminal-based text editor'
pkgname=mle
-pkgver=1.5.0
+pkgver=1.7.2
pkgrel=1
url='https://github.com/adsr/mle'
license=(Apache)
arch=(x86_64)
conflicts=(mle-git)
-depends=(pcre lua)
+depends=(pcre2 lua)
makedepends=(uthash)
source=("${url}/archive/v${pkgver}.tar.gz")
-sha512sums=('b96462dee4212a006a7e93c76954315bb0ead2f28be5e206e3918d9dae2cece6ebf76e6531468f178eb551cd23840ff4c8a77cbedde18808e1c8fd80f25fef49')
+b2sums=('a1a29e97245e5604608039b25f8f5c2e9bb27939f795d52d61fa57e679731c06680e75b0fe0dbe80dca511899422d757da0ba73023e2ecf8d937455fa621a78a')
prepare () {
- cd "${pkgname}-${pkgver}"
- # Avoid locale-dependent assertion
- # See https://github.com/adsr/mle/commit/e4dc4314b02a324701d9ae9873461d34cce041e5
- sed -i '/0wv/d' tests/unit/test_bline_insert.c
-
# The Arch Linux Lua package does not have an include/lua5.4 subdir,
# per-version subdirs are only available for the older releases; but
# mle.h wants to use lua5.4/lua*.h nevertheless.
- ln -snf /usr/include lua5.4
+ ln -snf /usr/include "${pkgname}-${pkgver}/lua5.4"
}
build () {