summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2019-01-07 17:45:10 +0200
committerAdrian Perez de Castro2019-01-07 17:48:03 +0200
commit1a505ce31a4de0e65e2d56bdfda76413a33bdc34 (patch)
tree6d9a069474b6d8fb01e4c3aed5e631d211a18af2
parent20fda273ebcedd431dac8a8e0484eb6c4a54a1d0 (diff)
downloadaur-1a505ce31a4de0e65e2d56bdfda76413a33bdc34.tar.gz
Remove usage of Git submodules, use packages instead
Use system-provided packages for UTHash, Lua, Termbox, and PCRE. This makes the vendored Git submodules unneeded and simplifies the packaging.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 17 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 141fb53dd57a..34a0033df4a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = mle-git
pkgdesc = Flexible terminal-based text editor
- pkgver = r365.157724d
+ pkgver = r379.af76670
pkgrel = 1
url = https://github.com/adsr/mle
arch = x86_64
- depends = pcre2
+ makedepends = git
+ makedepends = uthash
+ depends = pcre
+ depends = termbox
+ depends = lua
source = mle-git::git+https://github.com/adsr/mle
- source = git+https://github.com/lua/lua
- source = git+https://github.com/adsr/mlbuf
- source = git+https://github.com/nsf/termbox
- source = git+https://github.com/troydhanson/uthash
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
sha512sums = SKIP
pkgname = mle-git
diff --git a/.gitignore b/.gitignore
index b79bb9d6f265..4424c35453ee 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,5 @@
-/lua/
-/mlbuf/
/mle-git/
-/termbox/
-/uthash/
+/*.log
/*.tar
/*.tar.*
/pkg/
diff --git a/PKGBUILD b/PKGBUILD
index ca84068664de..0a79049706d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,14 @@
# Maintainer: Adrián Pérez de Castro
pkgdesc='Flexible terminal-based text editor'
pkgname=mle-git
-pkgver=r365.157724d
+pkgver=r379.af76670
pkgrel=1
arch=(x86_64)
url='https://github.com/adsr/mle'
-depends=(pcre2)
-source=("${pkgname}::git+${url}"
- git+https://github.com/lua/lua
- git+https://github.com/adsr/mlbuf
- git+https://github.com/nsf/termbox
- git+https://github.com/troydhanson/uthash
-)
-sha512sums=(SKIP SKIP SKIP SKIP SKIP)
+depends=(pcre termbox lua)
+makedepends=(git uthash)
+source=("${pkgname}::git+${url}")
+sha512sums=(SKIP)
pkgver () {
cd "${pkgname}"
@@ -25,12 +21,11 @@ pkgver () {
prepare () {
cd "${pkgname}"
- git submodule init
- local m
- for m in mlbuf termbox uthash ; do
- git config "submodule.${m}.url" "${srcdir}/${m}"
- done
- git submodule update
+
+ # The source code uses <lua5.3/lua.h>; and the Arch Linux "lua" package
+ # places the headers directly under /usr/include, so let's just use a
+ # symlink to provide the headers at the expected include location.
+ ln -snf /usr/include lua5.3
}
build () {