summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-11-14 01:28:30 +0100
committerAdrian Perez de Castro2018-11-14 01:28:30 +0100
commit20fda273ebcedd431dac8a8e0484eb6c4a54a1d0 (patch)
tree786ff57354bdbac171b452998c6f1192c2ddbc48
downloadaur-20fda273ebcedd431dac8a8e0484eb6c4a54a1d0.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD44
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..141fb53dd57a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mle-git
+ pkgdesc = Flexible terminal-based text editor
+ pkgver = r365.157724d
+ pkgrel = 1
+ url = https://github.com/adsr/mle
+ arch = x86_64
+ depends = pcre2
+ source = mle-git::git+https://github.com/adsr/mle
+ source = git+https://github.com/lua/lua
+ source = git+https://github.com/adsr/mlbuf
+ source = git+https://github.com/nsf/termbox
+ source = git+https://github.com/troydhanson/uthash
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = mle-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b79bb9d6f265
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+/lua/
+/mlbuf/
+/mle-git/
+/termbox/
+/uthash/
+/*.tar
+/*.tar.*
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca84068664de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Adrián Pérez de Castro
+pkgdesc='Flexible terminal-based text editor'
+pkgname=mle-git
+pkgver=r365.157724d
+pkgrel=1
+arch=(x86_64)
+url='https://github.com/adsr/mle'
+depends=(pcre2)
+source=("${pkgname}::git+${url}"
+ git+https://github.com/lua/lua
+ git+https://github.com/adsr/mlbuf
+ git+https://github.com/nsf/termbox
+ git+https://github.com/troydhanson/uthash
+)
+sha512sums=(SKIP SKIP SKIP SKIP SKIP)
+
+pkgver () {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare () {
+ cd "${pkgname}"
+ git submodule init
+ local m
+ for m in mlbuf termbox uthash ; do
+ git config "submodule.${m}.url" "${srcdir}/${m}"
+ done
+ git submodule update
+}
+
+build () {
+ cd "${pkgname}"
+ make prefix=/usr
+}
+
+package () {
+ cd "${pkgname}"
+ make prefix=/usr DESTDIR="${pkgdir}" install
+}