summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-05-30 23:01:51 +0300
committerAdrian Perez de Castro2022-05-30 23:01:51 +0300
commit45ebe4772a0ee77a8955465acf7af345eb8dca66 (patch)
tree0ea7187d8990deeb53ebd3a9faf4ab361d9b66aa
parentbf66dd59c16fae26bcc1363a642c626a269cc876 (diff)
downloadaur-45ebe4772a0ee77a8955465acf7af345eb8dca66.tar.gz
Update to upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cf25fdd3764..232822db8be5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = mle-git
pkgdesc = Flexible terminal-based text editor
- pkgver = r379.af76670
- pkgrel = 3
+ pkgver = r503.e4dc431
+ pkgrel = 1
url = https://github.com/adsr/mle
arch = x86_64
license = Apache
makedepends = git
makedepends = uthash
depends = pcre
- depends = termbox
depends = lua
source = mle-git::git+https://github.com/adsr/mle
sha512sums = SKIP
pkgname = mle-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0c0b236915c2..ec84f6f9fbe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Adrián Pérez de Castro
pkgdesc='Flexible terminal-based text editor'
pkgname=mle-git
-pkgver=r379.af76670
-pkgrel=3
-arch=(x86_64)
+pkgver=r503.e4dc431
+pkgrel=1
url='https://github.com/adsr/mle'
license=(Apache)
-depends=(pcre termbox lua)
+arch=(x86_64)
+depends=(pcre lua)
makedepends=(git uthash)
source=("${pkgname}::git+${url}")
sha512sums=(SKIP)
@@ -22,11 +22,14 @@ pkgver () {
prepare () {
cd "${pkgname}"
+ # Avoid locale-dependent assertion
+ # See https://github.com/adsr/mle/commit/e4dc4314b02a324701d9ae9873461d34cce041e5
+ sed -i '/0wv/d' tests/unit/test_bline_insert.c
- # The source code uses <lua5.3/lua.h>; and the Arch Linux "lua" package
- # places the headers directly under /usr/include, so let's just use a
- # symlink to provide the headers at the expected include location.
- ln -snf /usr/include lua5.3
+ # The Arch Linux Lua package does not have an include/lua5.4 subdir,
+ # per-version subdirs are only available for the older releases; but
+ # mle.h wants to use lua5.4/lua*.h nevertheless.
+ ln -snf /usr/include lua5.4
}
build () {