summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Taylor2024-03-27 19:52:03 +0000
committerMatt Taylor2024-03-27 19:52:03 +0000
commit0831047d0b34cef69d06cd3655daf04067da74cf (patch)
treed2eaa0cc9932255aa0992cfc8a76d78d392b2801
parent962398812ccaeb827cdc4bdcb39b46cd98319ba2 (diff)
downloadaur-0831047d0b34cef69d06cd3655daf04067da74cf.tar.gz
mlibc: bump to 5.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD16
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7445f6f82055..19f8d485209e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mlibc
pkgdesc = A portable C standard library
- pkgver = 4.0.0_rc1
+ pkgver = 5.0.0
pkgrel = 1
url = https://github.com/managarm/mlibc
arch = x86_64
@@ -18,13 +18,15 @@ pkgbase = mlibc
makedepends = python
makedepends = zstd
options = staticlibs
- source = mlibc-4.0.0.tar.gz::https://github.com/managarm/mlibc/archive/refs/tags/4.0.0-rc1.tar.gz
- source = gcc-13.2.0::git+https://github.com/managarm/gcc.git#commit=e5a5732020128cc6814cdfe65b05d6bb0f262e09
- source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.42.tar.gz
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.7.6.tar.xz
- md5sums = 3c41fea991ff084f2df7cad8ae0c5363
- md5sums = SKIP
- md5sums = d7569f3604d986c7d7c36a15176db89d
- md5sums = 8b4a23ce33184bcd4e9c4b9ff0e5ddb0
+ source = mlibc-5.0.0.tar.gz::https://github.com/managarm/mlibc/archive/refs/tags/5.0.0.tar.gz
+ source = gcc-managarm-13.2.3.tar.gz::https://github.com/managarm/gcc/archive/refs/tags/managarm/gcc-13.2.3.tar.gz
+ source = binutils-managarm-2.40.tar.gz::https://github.com/managarm/binutils-gdb/archive/refs/tags/managarm/binutils-2_40_2.tar.gz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.8.1.tar.xz
+ source = config.sub::https://git.savannah.gnu.org/cgit/config.git/plain/config.sub?id=948ae97ca5703224bd3eada06b7a69f40dd15a02
+ md5sums = 870d607b8d4c5922a74653af8a5625cd
+ md5sums = b6d5828e1392c9e84fb86fb2735c5fd8
+ md5sums = d277da5a45da1e0323f1e4eb571f8f53
+ md5sums = c4423a42f1e32d9decf17897eaca15ee
+ md5sums = e14e81807d4870d70f29ec131aed4ab2
pkgname = mlibc
diff --git a/PKGBUILD b/PKGBUILD
index f446b4ed2580..a014ffe8fb55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Matt Taylor <64.delta@proton.me>
# https://github.com/64/aur-packages for pull requests and issues.
pkgname=mlibc
-pkgver=4.0.0_rc1
-pkgrel=2
+pkgver=5.0.0
+pkgrel=1
pkgdesc="A portable C standard library"
arch=('x86_64')
url="https://github.com/managarm/mlibc"
@@ -32,17 +32,17 @@ install=
changelog=
GCCVER=13.2.3
BINUTILSVER=2.40
-LINUXVER=6.7.6
-source=("${pkgname}-4.0.0.tar.gz::https://github.com/managarm/mlibc/archive/refs/tags/4.0.0-rc1.tar.gz"
+LINUXVER=6.8.1
+source=("$pkgname-$pkgver.tar.gz::https://github.com/managarm/mlibc/archive/refs/tags/$pkgver.tar.gz"
"gcc-managarm-$GCCVER.tar.gz::https://github.com/managarm/gcc/archive/refs/tags/managarm/gcc-$GCCVER.tar.gz"
"binutils-managarm-$BINUTILSVER.tar.gz::https://github.com/managarm/binutils-gdb/archive/refs/tags/managarm/binutils-2_40_2.tar.gz"
"https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-$LINUXVER.tar.xz"
"config.sub::https://git.savannah.gnu.org/cgit/config.git/plain/config.sub?id=948ae97ca5703224bd3eada06b7a69f40dd15a02")
noextract=()
-md5sums=('3c41fea991ff084f2df7cad8ae0c5363'
+md5sums=('870d607b8d4c5922a74653af8a5625cd'
'b6d5828e1392c9e84fb86fb2735c5fd8'
'd277da5a45da1e0323f1e4eb571f8f53'
- '8b4a23ce33184bcd4e9c4b9ff0e5ddb0'
+ 'c4423a42f1e32d9decf17897eaca15ee'
'e14e81807d4870d70f29ec131aed4ab2')
validpgpkeys=()
@@ -53,7 +53,7 @@ sysroot_install_linux_headers() {
}
sysroot_install_mlibc() {
- cd "$pkgname-4.0.0-rc1"
+ cd "$pkgname-$pkgver"
# The default flags include -fexceptions which requires libgcc.
CFLAGS=${CFLAGS//"-fexceptions"}
@@ -144,5 +144,5 @@ package() {
ln -s "$PREFIX/bin/$CARCH-linux-mlibc-gcc" "$pkgdir/usr/bin/mlibc-gcc"
ln -s "$PREFIX/bin/$CARCH-linux-mlibc-g++" "$pkgdir/usr/bin/mlibc-g++"
- install -Dm644 "./$pkgname-4.0.0-rc1/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "./$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}