summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2020-06-01 11:19:24 +1000
committerRhinoceros2020-06-01 11:19:24 +1000
commit309fc5f8f0892c9ee6d86371bba39033c73a0d8b (patch)
tree5b4720fb0b35b7d3eccca3f9b7772d95b380ac19
downloadaur-309fc5f8f0892c9ee6d86371bba39033c73a0d8b.tar.gz
Initial commit of 1.2.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a36199db71f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mlink
+ pkgdesc = A tool connecting mBlock web version to devices
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://www.mblock.cc/en-us/download
+ arch = x86_64
+ license = custom
+ source = https://dl.makeblock.com/mblock5/linux/mLink-1.2.0-1.el7.x86_64.rpm
+ sha256sums = 1625de43bd7639ce87c3d0b05bac82336df8860351b35f113f93d0140b830c3b
+
+pkgname = mlink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bef26a61ac24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=mlink
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='A tool connecting mBlock web version to devices'
+arch=(x86_64)
+url='https://www.mblock.cc/en-us/download'
+# main program licence is unknown, but bundled node_modules are various
+license=(custom)
+# use rpm not deb, because (a) makepkg auto-expands rpms and (b) permissions in rpm are already correct for mlink
+# source=("https://dl.makeblock.com/mblock5/linux/mLink-1.2.0-amd64.deb")
+source=("https://dl.makeblock.com/mblock5/linux/mLink-1.2.0-1.el7.x86_64.rpm")
+sha256sums=('1625de43bd7639ce87c3d0b05bac82336df8860351b35f113f93d0140b830c3b')
+
+prepare() {
+ mkdir usr/bin
+ ln -s /usr/local/makeblock/mLink/mlink usr/bin/mblock-mlink
+}
+
+package() {
+ cp -r usr "${pkgdir}"
+}