summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuintus2017-05-29 11:40:33 +0000
committerQuintus2017-05-29 11:40:33 +0000
commit6bd0c9553b9aa65a0e250f93d7d49c961ce7ca7c (patch)
tree760d684a4dfa29b425580badf2dabd67094588c2
parent3c94f409f1b473c710572edc41b5ef50037579c5 (diff)
downloadaur-6bd0c9553b9aa65a0e250f93d7d49c961ce7ca7c.tar.gz
Upgrade to version 1.3.0.
The package also now includes mlmmj's documentation text files in /usr/share/doc/mlmmj. A licensing information error was fixed; mlmmj is licensed under the MIT license, not under GPL. This was incorrectly tagged in the metadata before. The 'license' field has been fixed accordingly and the license files are now included in the package as well.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec01112ad8e5..e9b77171cbba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = mlmmj
- pkgdesc = Mailing-list manager
- pkgver = 1.2.19.0
+ pkgdesc = Simple and slim mailing-list manager inspired by ezmlm
+ pkgver = 1.3.0
pkgrel = 1
url = http://mlmmj.org/
arch = i686
arch = x86_64
- license = GPL
+ license = MIT
depends = sh
- source = http://mlmmj.org/releases/mlmmj-1.2.19.0.tar.bz2
- sha256sums = 3bcd7f5a17234ef570836f043ea4aacfdaf47d542c4ad4cbe4b2293c3bdb3cde
+ source = http://mlmmj.org/releases/mlmmj-1.3.0.tar.bz2
+ sha256sums = 1c5d898143433147aa1b448fe041b2eecf6ab1601d451d426441a0a63008f242
pkgname = mlmmj
diff --git a/PKGBUILD b/PKGBUILD
index 17c51bd45156..62fa6ccc3f50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Pierre Chapuis <catwell at archlinux dot us>
pkgname='mlmmj'
-pkgver=1.2.19.0
+pkgver=1.3.0
pkgrel=1
-pkgdesc='Mailing-list manager'
+pkgdesc='Simple and slim mailing-list manager inspired by ezmlm'
depends=('sh')
arch=('i686' 'x86_64')
url='http://mlmmj.org/'
-license=('GPL')
+license=('MIT')
source=("http://mlmmj.org/releases/$pkgname-$pkgver.tar.bz2")
-sha256sums=('3bcd7f5a17234ef570836f043ea4aacfdaf47d542c4ad4cbe4b2293c3bdb3cde')
+sha256sums=('1c5d898143433147aa1b448fe041b2eecf6ab1601d451d426441a0a63008f242')
build() {
cd $pkgname-$pkgver
@@ -21,4 +21,15 @@ build() {
package() {
cd $pkgname-$pkgver
make DESTDIR=$pkgdir install
+
+ install -D -m 0644 LICENSE $pkgdir/usr/share/licenses/mlmmj/LICENSE
+ install -D -m 0644 COPYING $pkgdir/usr/share/licenses/mlmmj/COPYING
+ install -D -m 0644 AUTHORS $pkgdir/usr/share/licenses/mlmmj/AUTHORS
+ install -D -m 0644 FAQ $pkgdir/usr/share/doc/mlmmj/FAQ
+ install -D -m 0644 TUNABLES $pkgdir/usr/share/doc/mlmmj/TUNABLES
+ install -D -m 0644 UPGRADE $pkgdir/usr/share/doc/mlmmj/UPGRADE
+
+ for f in `ls README*`; do
+ install -D -m 0644 $f $pkgdir/usr/share/doc/mlmmj/$f
+ done
}