summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGovind Gopakumar2014-02-27 00:46:38 +0000
committerjerry732042015-10-29 11:57:37 +0800
commit05ace840f873a1005f56205ce99659f6f48f9ce7 (patch)
tree89cf0132c09d8db8401bcbd4ca5cedd294a84342
parent5f4539beabb9bdee5a2da0474ba7f3c0814f5c7e (diff)
downloadaur-05ace840f873a1005f56205ce99659f6f48f9ce7.tar.gz
updated on Thu Feb 27 00:46:35 UTC 2014
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7e94ebf024f..c5737391cb37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = mlpack
pkgdesc = a scalable c++ machine learning library
- pkgver = 1.0.5
+ pkgver = 1.0.8
pkgrel = 1
url = http://www.mlpack.org
arch = i686
arch = x86_64
- license = LGPLv3+
+ license = LGPLv3
makedepends = cmake>=2.8.0
makedepends = txt2man
- depends = armadillo>=2.4.0
+ depends = armadillo>=3.6.0
depends = boost
depends = lapack
- depends = libxml2
- source = http://www.mlpack.org/files/mlpack-1.0.5.tar.gz
- md5sums = f3ae9ed8c85983aa3a5cf8878ec4a5d2
+ depends = libxml2>=2.6.0
+ source = http://www.mlpack.org/files/mlpack-1.0.8.tar.gz
+ md5sums = 0331e12f2485b9d5d39c9d9dea618108
pkgname = mlpack
diff --git a/PKGBUILD b/PKGBUILD
index 5d089e89f313..3d42e8454057 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Former Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Adopted by: Govind Gopakumar < govind.93 at gmail dot com>
pkgname=mlpack
-pkgver=1.0.5
+pkgver=1.0.8
pkgrel=1
pkgdesc="a scalable c++ machine learning library"
arch=('i686' 'x86_64')
url="http://www.mlpack.org"
-license=('LGPLv3+')
-depends=('armadillo>=2.4.0' 'boost' 'lapack' 'libxml2')
+license=('LGPLv3')
+depends=('armadillo>=3.6.0' 'boost' 'lapack' 'libxml2>=2.6.0')
makedepends=('cmake>=2.8.0' 'txt2man')
source=("http://www.$pkgname.org/files/${pkgname}-${pkgver}.tar.gz")
-md5sums=('f3ae9ed8c85983aa3a5cf8878ec4a5d2')
+md5sums=('0331e12f2485b9d5d39c9d9dea618108')
build() {
cd "$srcdir/$pkgname-$pkgver"
- cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/" -D DEBUG=OFF -D PROFILE=OFF .
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -D DEBUG=OFF -D PROFILE=OFF .
make
}