summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjerry732042016-06-25 12:45:09 +0800
committerjerry732042016-06-25 12:45:31 +0800
commit26255fd2aae53876154845f6003b8933b73827de (patch)
treeaa1f1adcd8857caf0400e67c6b770227fb7726a5
parent605381b99c252e8dc56a5bc28bd42720b98f887a (diff)
downloadaur-26255fd2aae53876154845f6003b8933b73827de.tar.gz
Updated to 2.0.2-1. Remove kmeans_impl.patch.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--kmeans_impl.patch13
3 files changed, 9 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 046a6dabd249..27b486b8b601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Apr 12 04:05:06 UTC 2016
+# Sat Jun 25 04:45:13 UTC 2016
pkgbase = mlpack
pkgdesc = a scalable c++ machine learning library
- pkgver = 2.0.1
- pkgrel = 2
+ pkgver = 2.0.2
+ pkgrel = 1
url = http://www.mlpack.org
arch = i686
arch = x86_64
@@ -14,10 +14,8 @@ pkgbase = mlpack
depends = boost>=1.49
depends = lapack
depends = libxml2>=2.6.0
- source = http://www.mlpack.org/files/mlpack-2.0.1.tar.gz
- source = kmeans_impl.patch
- sha1sums = 27df05cff83d202f5d64a3d3fa4bdc4d9a6bc4be
- sha1sums = 0d9801873e44d340185081b9d1398bf60a37771b
+ source = http://www.mlpack.org/files/mlpack-2.0.2.tar.gz
+ sha1sums = 6038dbc9930e5699540cd51b5186d265f78cdb21
pkgname = mlpack
diff --git a/PKGBUILD b/PKGBUILD
index 904b9b2c6424..9f22c441ce86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Former Maintainer: Govind Gopakumar < govind.93 at gmail dot com>
# Former Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=mlpack
-pkgver=2.0.1
-pkgrel=2
+pkgver=2.0.2
+pkgrel=1
pkgdesc='a scalable c++ machine learning library'
arch=('i686' 'x86_64')
url="http://www.mlpack.org"
@@ -13,15 +13,11 @@ depends=('armadillo>=4.100.0'
'lapack'
'libxml2>=2.6.0')
makedepends=('cmake>=2.8.5' 'txt2man')
-source=("http://www.mlpack.org/files/${pkgname}-${pkgver}.tar.gz"
- 'kmeans_impl.patch')
-sha1sums=('27df05cff83d202f5d64a3d3fa4bdc4d9a6bc4be'
- '0d9801873e44d340185081b9d1398bf60a37771b')
+source=("http://www.mlpack.org/files/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('6038dbc9930e5699540cd51b5186d265f78cdb21')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch -Np1 < "${srcdir}/kmeans_impl.patch"
}
build() {
diff --git a/kmeans_impl.patch b/kmeans_impl.patch
deleted file mode 100644
index 13748f07b6a8..000000000000
--- a/kmeans_impl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/mlpack/methods/kmeans/kmeans_impl.hpp b/src/mlpack/methods/kmeans/kmeans_impl.hpp
-index c3254b3..20681cc 100644
---- a/src/mlpack/methods/kmeans/kmeans_impl.hpp
-+++ b/src/mlpack/methods/kmeans/kmeans_impl.hpp
-@@ -175,7 +175,7 @@ Cluster(const MatType& data,
- iteration++;
- Log::Info << "KMeans::Cluster(): iteration " << iteration << ", residual "
- << cNorm << ".\n";
-- if (isnan(cNorm) || isinf(cNorm))
-+ if (std::isnan(cNorm) || std::isinf(cNorm))
- cNorm = 1e-4; // Keep iterating.
-
- } while (cNorm > 1e-5 && iteration != maxIterations);