summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Hueso Gomez2020-07-15 17:10:36 +0200
committerRoberto Hueso Gomez2020-07-15 17:21:41 +0200
commit405a1570565e3669952dfb2f33ff38dec0b6d13b (patch)
treeafdfa5b1b07008950e2344496631605a385e01d2
parent87c55981fa6e7662878c64b68f6b2389fe73935f (diff)
downloadaur-405a1570565e3669952dfb2f33ff38dec0b6d13b.tar.gz
Update to 3.3.2-1
This update: - Removes BUILD_JULIA_BINDINGS - This option now fails in case julia is not available. Without it, this tries to build julia bindings if available. - Adds support for go bindings if available. - This is added as an optional dependency.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b801577a36b9..73f18577896f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mlpack
pkgdesc = A fast, flexible, scalable C++ machine learning library
- pkgver = 3.3.1
+ pkgver = 3.3.2
pkgrel = 1
url = https://mlpack.org/
arch = x86_64
@@ -17,8 +17,9 @@ pkgbase = mlpack
depends = python-pandas>=0.15.0
optdepends = openmp: parallel computation support
optdepends = julia>=2:1.3.0: julia bindings support
- source = https://www.mlpack.org/files/mlpack-3.3.1.tar.gz
- sha256sums = 310f95faa93b975c1489344ae4a499eddcd825ef9db76909eb680e1695cd1e36
+ optdepends = go>=2:1.12.9-1: go bindings support
+ source = https://www.mlpack.org/files/mlpack-3.3.2.tar.gz
+ sha256sums = 11904a39a7e34ee66028292fd054afb460eacd07ec5e6c63789aba117e4d854c
pkgname = mlpack
diff --git a/PKGBUILD b/PKGBUILD
index 96041ece240d..14ad58edf13c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Former Maintainer: Govind Gopakumar < govind.93 at gmail dot com>
# Former Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=mlpack
-pkgver=3.3.1
+pkgver=3.3.2
pkgrel=1
pkgdesc='A fast, flexible, scalable C++ machine learning library'
arch=('x86_64')
@@ -22,6 +22,7 @@ depends=(
optdepends=(
'openmp: parallel computation support'
'julia>=2:1.3.0: julia bindings support'
+ 'go>=2:1.12.9-1: go bindings support'
)
makedepends=(
@@ -30,7 +31,7 @@ makedepends=(
'python-setuptools'
)
source=("https://www.mlpack.org/files/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('310f95faa93b975c1489344ae4a499eddcd825ef9db76909eb680e1695cd1e36')
+sha256sums=('11904a39a7e34ee66028292fd054afb460eacd07ec5e6c63789aba117e4d854c')
options=(!emptydirs)
prepare() {
@@ -45,7 +46,6 @@ build() {
-D CMAKE_INSTALL_PREFIX="/usr" \
-D BUILD_CLI_EXECUTABLES=ON \
-D BUILD_PYTHON_BINDINGS=ON \
- -D BUILD_JULIA_BINDINGS=ON \
-D BUILD_TESTS=OFF \
-D USE_OPENMP=ON \
..