summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Hueso Gomez2020-05-01 15:03:45 +0200
committerRoberto Hueso Gomez2020-05-01 15:03:45 +0200
commit87c55981fa6e7662878c64b68f6b2389fe73935f (patch)
tree3ecf35977d704986ee04dcc76bc6faad679aa986
parent8423b5516b61e96d7a6864491dd1f543a4196683 (diff)
downloadaur-87c55981fa6e7662878c64b68f6b2389fe73935f.tar.gz
Update to 3.3.1-1
This patch also: - Adds julia as an optional dependency. - Upgrades boost dependency.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ecab009f626..b801577a36b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mlpack
pkgdesc = A fast, flexible, scalable C++ machine learning library
- pkgver = 3.2.2
+ pkgver = 3.3.1
pkgrel = 1
url = https://mlpack.org/
arch = x86_64
@@ -9,16 +9,16 @@ pkgbase = mlpack
makedepends = txt2man
makedepends = python-setuptools
depends = armadillo>=8.400.0
- depends = boost>=1.49
+ depends = boost>=1.58
depends = lapack
depends = ensmallen>=2.10.0
- depends = libxml2>=2.6.0
depends = cython>=0.24
depends = python-numpy
depends = python-pandas>=0.15.0
optdepends = openmp: parallel computation support
- source = https://www.mlpack.org/files/mlpack-3.2.1.tar.gz
- sha256sums = 7aef8c27645c9358262fec9ebba380720a086789d6519d5d1034346412a52ad6
+ optdepends = julia>=2:1.3.0: julia bindings support
+ source = https://www.mlpack.org/files/mlpack-3.3.1.tar.gz
+ sha256sums = 310f95faa93b975c1489344ae4a499eddcd825ef9db76909eb680e1695cd1e36
pkgname = mlpack
diff --git a/PKGBUILD b/PKGBUILD
index d185c904ac0c..96041ece240d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Former Maintainer: Govind Gopakumar < govind.93 at gmail dot com>
# Former Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=mlpack
-pkgver=3.2.2
+pkgver=3.3.1
pkgrel=1
pkgdesc='A fast, flexible, scalable C++ machine learning library'
arch=('x86_64')
@@ -11,10 +11,9 @@ url="https://mlpack.org/"
license=('BSD')
depends=(
'armadillo>=8.400.0'
- 'boost>=1.49'
+ 'boost>=1.58'
'lapack'
'ensmallen>=2.10.0'
- 'libxml2>=2.6.0'
'cython>=0.24'
'python-numpy'
'python-pandas>=0.15.0'
@@ -22,6 +21,7 @@ depends=(
optdepends=(
'openmp: parallel computation support'
+ 'julia>=2:1.3.0: julia bindings support'
)
makedepends=(
@@ -30,7 +30,7 @@ makedepends=(
'python-setuptools'
)
source=("https://www.mlpack.org/files/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('7aef8c27645c9358262fec9ebba380720a086789d6519d5d1034346412a52ad6')
+sha256sums=('310f95faa93b975c1489344ae4a499eddcd825ef9db76909eb680e1695cd1e36')
options=(!emptydirs)
prepare() {
@@ -43,7 +43,9 @@ build() {
cmake \
-D CMAKE_INSTALL_PREFIX="/usr" \
+ -D BUILD_CLI_EXECUTABLES=ON \
-D BUILD_PYTHON_BINDINGS=ON \
+ -D BUILD_JULIA_BINDINGS=ON \
-D BUILD_TESTS=OFF \
-D USE_OPENMP=ON \
..