summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjerry732042018-06-15 22:25:23 +0800
committerjerry732042018-06-15 22:25:23 +0800
commit969ffe4d6a077201a2fc3d99976e262b23b5615d (patch)
tree445ae365e6c7927150ae9c7cbc9c358cb9692394
parentc478fa00906517a9f077bd8e0ffc51ebcf2d0cca (diff)
downloadaur-969ffe4d6a077201a2fc3d99976e262b23b5615d.tar.gz
Updated to 3.0.2-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12abb94f8ac1..bc18bb7bfe7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon May 14 19:39:19 UTC 2018
+# Fri Jun 15 14:24:58 UTC 2018
pkgbase = mlpack
pkgdesc = a scalable c++ machine learning library
- pkgver = 3.0.1
+ pkgver = 3.0.2
pkgrel = 1
url = http://www.mlpack.org
arch = i686
@@ -19,8 +19,8 @@ pkgbase = mlpack
depends = cython>=0.24
depends = python-numpy
depends = python-pandas>=0.15.0
- source = http://www.mlpack.org/files/mlpack-3.0.1.tar.gz
- sha256sums = 74fe128e1c12fa760885def6ce8bee58e6c4dfd1364e186a60521c543654202f
+ source = http://www.mlpack.org/files/mlpack-3.0.2.tar.gz
+ sha256sums = 69e81178839594049d84526b8f9612825f238f7cfe1f6d579bd6461ed48e5aa0
pkgname = mlpack
diff --git a/PKGBUILD b/PKGBUILD
index 1be6e35a8e68..7512fcf34f41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Former Maintainer: Govind Gopakumar < govind.93 at gmail dot com>
# Former Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=mlpack
-pkgver=3.0.1
+pkgver=3.0.2
pkgrel=1
pkgdesc='a scalable c++ machine learning library'
arch=('i686' 'x86_64')
@@ -24,7 +24,7 @@ makedepends=(
'python-pytest-runner'
)
source=("http://www.mlpack.org/files/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('74fe128e1c12fa760885def6ce8bee58e6c4dfd1364e186a60521c543654202f')
+sha256sums=('69e81178839594049d84526b8f9612825f238f7cfe1f6d579bd6461ed48e5aa0')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -36,15 +36,15 @@ build() {
make
}
-# check() {
-# # Comment out check() if there are failed tests. If you consider it a bug,
-# # please file an issue on upstream instead of AUR.
+check() {
+ # Comment out check() if there are failed tests. If you consider it a bug,
+ # please file an issue on upstream instead of AUR.
-# cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
-# make mlpack_test
-# bin/mlpack_test
-# }
+ make mlpack_test
+ bin/mlpack_test
+}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"