summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Wallace2012-10-13 23:00:14 +0000
committerjerry732042015-10-29 11:57:08 +0800
commitec1c04ffc5ab842787f143c56d97d563d03cd585 (patch)
tree9be4ecf43a3fd78b237bf18aa17df803c363ddb3
parent3611cc835e7cca080741639f4a67d7e005afe037 (diff)
downloadaur-ec1c04ffc5ab842787f143c56d97d563d03cd585.tar.gz
updated on Sat Oct 13 23:00:14 UTC 2012
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fed6feb0317..8c571507825a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mlpack
pkgdesc = a scalable c++ machine learning library
- pkgver = 1.0.1
+ pkgver = 1.0.3
pkgrel = 1
url = http://www.mlpack.org
arch = i686
@@ -12,12 +12,12 @@ pkgbase = mlpack
depends = boost
depends = lapack
depends = libxml2
- source = http://www.mlpack.org/files/mlpack-1.0.1.tar.gz
+ source = http://www.mlpack.org/files/mlpack-1.0.3.tar.gz
source = http://www.mlpack.org/files/range_search_install.patch
source = http://www.mlpack.org/files/getkernelmatrix_definition.patch
source = http://www.mlpack.org/files/no_sparse_tests.patch
source = http://www.mlpack.org/files/fully_qualified_as_scalar.patch
- md5sums = ecf9279fc8e92836aeb838c127ab79f6
+ md5sums = 9c61f73e2c479315f8270b205315df23
md5sums = 352cdbadf79e6bc17f71c536b0113dae
md5sums = 81d7bea820041a7caa4b2683e536ee1f
md5sums = 44991787106e33443af03c225ab92a3f
diff --git a/PKGBUILD b/PKGBUILD
index 2841d9363aeb..c4c5a8535211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=mlpack
-pkgver=1.0.1
+pkgver=1.0.3
pkgrel=1
pkgdesc="a scalable c++ machine learning library"
arch=('i686' 'x86_64')
@@ -23,10 +23,10 @@ md5sums=('ecf9279fc8e92836aeb838c127ab79f6'
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -i "$srcdir/${source[1]##*/}"
- patch -Np1 -i "$srcdir/${source[2]##*/}"
- patch -Np1 -i "$srcdir/${source[3]##*/}"
- patch -Np1 -i "$srcdir/${source[4]##*/}"
+ #patch -Np1 -i "$srcdir/${source[1]##*/}"
+ #patch -Np1 -i "$srcdir/${source[2]##*/}"
+ #patch -Np1 -i "$srcdir/${source[3]##*/}"
+ #patch -Np1 -i "$srcdir/${source[4]##*/}"
cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/" -D DEBUG=OFF -D PROFILE=OFF .
make
@@ -46,3 +46,8 @@ package() {
}
# vim:set ts=2 sw=2 et:
+md5sums=('9c61f73e2c479315f8270b205315df23'
+ '352cdbadf79e6bc17f71c536b0113dae'
+ '81d7bea820041a7caa4b2683e536ee1f'
+ '44991787106e33443af03c225ab92a3f'
+ 'e79dc29cbb5e0575dbc3110c46650e50')