summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarazok2020-12-10 12:17:20 +0100
committerBarazok2020-12-10 12:17:20 +0100
commit7fd2d0434f286496136b7c5647583a55ce525654 (patch)
tree52d6c600cfde23df62e13066b33603852a7b8f34
parentef4e18ba5b9f2e888ed871f87d281ae7f1186cc0 (diff)
downloadaur-7fd2d0434f286496136b7c5647583a55ce525654.tar.gz
Fetchin deb packages instead of fetching sources and building them
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0317dd9ab62..aec1676768e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Barazok <barazok.blackrocks@gmail.com>
pkgname=mlv
pkgver=2.0.2
-pkgrel=3
+pkgrel=4
pkgdesc="The MLV library is a simplified multimedia library. This library is ideal for students who are new to C programming and want to add graphic and sound effects to their programs."
arch=('any')
url="http://www-igm.univ-mlv.fr/~boussica/mlv/api/French/html/index.html"
@@ -17,19 +17,11 @@ backup=()
options=()
install=
changelog=
-source=(http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/mlv-2.0.2.tar.gz)
-noextract=()
-md5sums=('1b29b677ea0123f92e4a0486139b57b1')
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr
- make
-}
+source=("http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/libmlv0_2.0.2-1_amd64.deb"
+ "http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/libmlv0-dev_2.0.2-1_amd64.deb")
+md5sums=("1c258a34b96c136aaf094772a172b874"
+ "2184ed0c53c0b29764e507aa17155811")
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir/" install
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
}