summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn K. Luebs2014-07-23 11:31:17 -0400
committerJohn K. Luebs2014-07-23 11:31:17 -0400
commit4f393d24ff113ccb03bf4302270b277d14a143c4 (patch)
treed482a1e6ab61ee411847030cf38242b8329ab30e
parent835bd185f4fd05b726fd8218310eace25726ec98 (diff)
downloadaur-4f393d24ff113ccb03bf4302270b277d14a143c4.tar.gz
mma: Upgrade to 14.07, reenable zipman
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rw-r--r--fix-mmastart-path.patch11
3 files changed, 6 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34c33c275f5d..ea8aa1a84bfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mma
pkgdesc = Musical MIDI Accompaniment (MMA) is an accompaniment generator
- pkgver = 13.12
+ pkgver = 14.07
pkgrel = 1
url = http://www.mellowood.ca/mma/
install = mma.install
@@ -9,13 +9,10 @@ pkgbase = mma
depends = python2>=2.5.0
depends = timidity++
options = !strip
- options = !zipman
backup = etc/mmarc
- source = http://www.mellowood.ca/mma/mma-bin-13.12.tar.gz
- source = fix-mmastart-path.patch
+ source = http://www.mellowood.ca/mma/mma-bin-14.07.tar.gz
source = mmarc
- sha1sums = 8db89bb03228c4567bc28add52336a24728280ee
- sha1sums = 59e4abe8a192e919b141cefbdf9660257266387f
+ sha1sums = daa430fed5264584d2a9ab1c2a5206143be4d7ef
sha1sums = 3c03107c2a1b380f66ed68458d9b9def8371c0f6
pkgname = mma
diff --git a/PKGBUILD b/PKGBUILD
index 02c3d598ffcf..8ed08526195b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# https://github.com/jkl1337/packages-archlinux.git
pkgname=mma
-pkgver=13.12
+pkgver=14.07
pkgrel=1
pkgdesc="Musical MIDI Accompaniment (MMA) is an accompaniment generator"
url="http://www.mellowood.ca/mma/"
@@ -17,18 +17,15 @@ arch=('any')
install=mma.install
DLAGENTS=('http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 --user-agent "Mozilla/4.0" -o %o %u ')
source=("http://www.mellowood.ca/mma/mma-bin-$pkgver.tar.gz"
- fix-mmastart-path.patch
mmarc)
-sha1sums=('8db89bb03228c4567bc28add52336a24728280ee'
- '59e4abe8a192e919b141cefbdf9660257266387f'
+sha1sums=('daa430fed5264584d2a9ab1c2a5206143be4d7ef'
'3c03107c2a1b380f66ed68458d9b9def8371c0f6')
-options=(!strip !zipman)
+options=(!strip)
backup=(etc/mmarc)
build () {
cd "$srcdir/$pkgname-bin-$pkgver"
- patch -p1 -i "$srcdir/fix-mmastart-path.patch"
for file in $(grep -rl 'env python *$' .); do sed -i 's/env python *$/env python2/g' $file ;done
}
diff --git a/fix-mmastart-path.patch b/fix-mmastart-path.patch
deleted file mode 100644
index 008fe1d205cb..000000000000
--- a/fix-mmastart-path.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mma-bin-12.10/MMA/main.py.orig 2012-10-20 19:29:35.000000000 -0400
-+++ mma-bin-12.10/MMA/main.py 2013-08-03 19:48:46.820508239 -0400
-@@ -156,7 +156,7 @@
- # First the mmastart files
-
- for f in gbl.mmaStart:
-- fn = MMA.file.locFile(f, MMA.paths.incPath)
-+ fn = MMA.paths.findIncFile(f)
- if not fn:
- warning("MmaStart file '%s' not found/processed" % fn)
- MMA.parse.parseFile(fn)