summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Pérez2020-09-25 11:29:38 -0600
committerLuis Pérez2020-09-25 11:29:38 -0600
commit834c25e4d8bf337c7c3606403d2510cfb6375505 (patch)
tree57c17d75b957ae5cd6ce2ed9c01b1aef63e7992b
downloadaur-834c25e4d8bf337c7c3606403d2510cfb6375505.tar.gz
mmark go package for markdown generation
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b4cbd03c213
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mmark
+ pkgdesc = A powerful markdown processor in Go geared towards the IETF
+ pkgver = 2.2.9
+ pkgrel = 1
+ url = https://github.com/mmarkdown/mmark
+ arch = x86_64
+ license = BSD
+ makedepends = go
+ makedepends = git
+ source = https://github.com/mmarkdown/mmark/archive/v2.2.9.tar.gz
+ sha256sums = 70f080363ab3590e02471a7a48d6efc976072374dcbccd09884667f2002993fb
+
+pkgname = mmark
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d6fb43651f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Luis Pérez <luis.perez@protonmail.com>
+pkgname=mmark
+pkgver=2.2.9
+pkgrel=1
+pkgdesc='A powerful markdown processor in Go geared towards the IETF'
+arch=('x86_64')
+url="https://github.com/mmarkdown/mmark"
+license=('BSD')
+makedepends=(
+ 'go'
+ 'git'
+)
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('70f080363ab3590e02471a7a48d6efc976072374dcbccd09884667f2002993fb')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}