summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Bernardoff2018-08-08 09:00:48 +0200
committerVincent Bernardoff2018-08-08 09:00:48 +0200
commitade92002e3dd9111a947d4dbda0c4ad9d3f1d6c1 (patch)
tree45428ae3069e2b34ce00241f50305793f45ffa3d
downloadaur-ade92002e3dd9111a947d4dbda0c4ad9d3f1d6c1.tar.gz
Initial commit.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--lsmmc.patch13
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8d6b46ba89a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Aug 8 06:57:33 UTC 2018
+pkgbase = mmc-utils-git
+ pkgdesc = Userspace tools for MMC/SD devices
+ pkgver = b4fe0c8.dirty
+ pkgrel = 1
+ url = https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = make
+ provides = mmc-utils
+ conflicts = mmc-utils
+ source = git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git
+ source = lsmmc.patch
+ sha256sums = SKIP
+ sha256sums = 169a9f6edb8deef993cf4f663eaca4f934d8c4b9ba308ada3300ea02a12f2281
+
+pkgname = mmc-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6dd5538d5ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Vincent Bernardoff <vb AT luminar.eu.org>
+pkgname=mmc-utils-git
+pkgver=b4fe0c8.dirty
+pkgrel=1
+pkgdesc="Userspace tools for MMC/SD devices"
+arch=(arm armv6h armv7h aarch64 x86_64 i686)
+url="https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git"
+license=('GPL')
+depends=()
+makedepends=('git' 'make')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=
+source=('git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git'
+ 'lsmmc.patch')
+noextract=()
+sha256sums=('SKIP'
+ '169a9f6edb8deef993cf4f663eaca4f934d8c4b9ba308ada3300ea02a12f2281')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --always --dirty --tags | sed -e 's/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ patch -p1 < ../lsmmc.patch
+}
+
+build() {
+ cd "${pkgname%-git}"
+ make all
+}
+
+# check() {
+# }
+
+package() {
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir/" prefix=/usr install
+ install -D man/mmc.1 "$pkgdir/usr/share/man/man1/mmc.1"
+}
diff --git a/lsmmc.patch b/lsmmc.patch
new file mode 100644
index 000000000000..1ab06ce0b2a4
--- /dev/null
+++ b/lsmmc.patch
@@ -0,0 +1,13 @@
+diff --git a/lsmmc.c b/lsmmc.c
+index c4faa00..0f748cd 100644
+--- a/lsmmc.c
++++ b/lsmmc.c
+@@ -353,7 +353,7 @@ char *read_file(char *name)
+ line[strlen(line) - 1] = '\0';
+
+ while (isspace(line[0]))
+- strncpy(&line[0], &line[1], sizeof(line));
++ memmove(&line[0], &line[1], sizeof(line) - 1);
+
+ return strdup(line);
+ }