summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Kracmar2015-07-24 11:03:23 +0200
committerEduard Kracmar2015-07-24 11:03:23 +0200
commitc94b104f3cf302dccf4fc3524340ebacc3cde26f (patch)
tree22f387bfa43861923f81699d4802e8e411193bdb
downloadaur-c94b104f3cf302dccf4fc3524340ebacc3cde26f.tar.gz
v3.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--mmonit.service12
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7063b356e104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mmonit
+ pkgdesc = Easy, proactive monitoring of Unix systems, network and cloud services. Conduct automatic maintenance and recovery and execute meaningful causal actions in error situations.
+ pkgver = 3.5
+ pkgrel = 2
+ url = http://mmonit.com/
+ arch = x86_64
+ license = Commercial
+ source = https://mmonit.com/dist/mmonit-3.5-linux-x64.tar.gz
+ source = mmonit.service
+ sha256sums = c872bd09811804ff4f41319507b77626926f3a028b56e2f320d470f07e032c7b
+ sha256sums = 9a4edf62ef3da3af1e3dcfebd7b3bb3f96e81c5a9767021f0e4ed775f2dbb469
+
+pkgname = mmonit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef253687f2cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id$
+# Maintainer: Eduard Kracmar <info[at]adaptiware[dot]com>
+
+pkgname=mmonit
+pkgver=3.5
+pkgrel=2
+pkgdesc="Easy, proactive monitoring of Unix systems, network and cloud services. Conduct automatic maintenance and recovery and execute meaningful causal actions in error situations."
+arch=('x86_64')
+url="http://mmonit.com/"
+license=('Commercial')
+#depends=('openssl')
+source=(https://mmonit.com/dist/$pkgname-$pkgver-linux-x64.tar.gz \
+ mmonit.service)
+
+package() {
+ mkdir -p $pkgdir/opt/$pkgname || return 1
+ cp -R $srcdir/$pkgname-$pkgver/* $pkgdir/opt/$pkgname || return 1
+ install -D -m644 ${srcdir}/$pkgname.service ${pkgdir}/usr/lib/systemd/system/$pkgname.service
+}
+
+sha256sums=('c872bd09811804ff4f41319507b77626926f3a028b56e2f320d470f07e032c7b'
+ '9a4edf62ef3da3af1e3dcfebd7b3bb3f96e81c5a9767021f0e4ed775f2dbb469')
+
+
diff --git a/mmonit.service b/mmonit.service
new file mode 100644
index 000000000000..5517eae9ef70
--- /dev/null
+++ b/mmonit.service
@@ -0,0 +1,12 @@
+[Unit]
+Description = Easy, proactive monitoring of Unix systems, network and cloud services
+After = network.target
+
+[Service]
+Type=forking
+ExecStart = /opt/mmonit/bin/mmonit start
+ExecStop = /opt/mmonit/bin/mmonit stop
+PIDFile = /opt/mmonit/logs/mmonit.pid
+
+[Install]
+WantedBy = multi-user.target