summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 14:58:06 +0200
committersmls2015-07-09 14:58:06 +0200
commit11e4c3d4b59c43248b81071ed737663fe7f1d316 (patch)
tree5f52eceb57866cb6545cfc8f69d79f71e18bc930
downloadaur-11e4c3d4b59c43248b81071ed737663fe7f1d316.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rw-r--r--mnemosyne.install7
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff363dc4b154
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mnemosyne
+ pkgdesc = A flash-card tool with a sophisticated card review algorithm
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = http://www.mnemosyne-proj.org
+ install = mnemosyne.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2-pyqt4
+ depends = python2-matplotlib
+ depends = python2-cherrypy
+ depends = python2-webob
+ optdepends = texlive-core: support for mathematical formulae in cards
+ conflicts = mnemosyne-bzr
+ source = http://downloads.sourceforge.net/mnemosyne-proj/Mnemosyne-2.3.3.tar.gz
+ md5sums = c1594959138b389600be97a99ba15dbd
+
+pkgname = mnemosyne
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81b85eadb120
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+# Contributor: Nuno Araujo <nuno.araujo@russo79.com>
+
+pkgname=mnemosyne
+pkgver=2.3.3
+pkgrel=1
+pkgdesc="A flash-card tool with a sophisticated card review algorithm"
+arch=('i686' 'x86_64')
+url='http://www.mnemosyne-proj.org'
+license=('GPL')
+depends=('python2-pyqt4' 'python2-matplotlib' 'python2-cherrypy' 'python2-webob')
+makedepends=('python2-setuptools')
+optdepends=('texlive-core: support for mathematical formulae in cards')
+conflicts=('mnemosyne-bzr')
+install='mnemosyne.install'
+
+source=("http://downloads.sourceforge.net/mnemosyne-proj/Mnemosyne-${pkgver}.tar.gz")
+md5sums=('c1594959138b389600be97a99ba15dbd')
+
+build() {
+ cd "${srcdir}/Mnemosyne-${pkgver}/"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/Mnemosyne-${pkgver}/"
+ python2 setup.py install --root="${pkgdir}"
+}
diff --git a/mnemosyne.install b/mnemosyne.install
new file mode 100644
index 000000000000..adfe7f90ad22
--- /dev/null
+++ b/mnemosyne.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo " When started, Mnemosyne 2.x looks for a Mnemosyne 1.x database in"
+ echo " ~/.mnemosyne/ and tries to automatically import it. It won't overwrite"
+ echo " it, though, as it stores its own database in ~/.local/share/mnemosyne/."
+ echo " After it has been successfully imported once, manually delete the old"
+ echo " ~/.mnemosyne/ folder so it won't be automatically imported again."
+}