summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2015-08-10 23:52:51 -0400
committerDavid Parrish2015-08-10 23:52:51 -0400
commit36ca69f7747473c25d2e115994071af3c455d0a4 (patch)
tree3bef9a0c164f941c0e413b3dfeabb78d8d9d73c3
downloadaur-36ca69f7747473c25d2e115994071af3c455d0a4.tar.gz
Initial commit for mo
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2426bed4d61b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mo-git
+ pkgdesc = Mustache templates in pure bash
+ pkgver = r39.e1b6815
+ pkgrel = 1
+ url = https://github.com/tests-always-included/mo
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = bash
+ source = mo-git::git+https://github.com/tests-always-included/mo.git
+ sha256sums = SKIP
+
+pkgname = mo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52459426fe1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=mo-git
+pkgver=r39.e1b6815
+pkgrel=1
+pkgdesc="Mustache templates in pure bash"
+arch=('i686' 'x86_64')
+url="https://github.com/tests-always-included/mo"
+license=('MIT')
+depends=('bash')
+source=("${pkgname}::git+https://github.com/tests-always-included/mo.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ ls $pkgname
+
+ # Install License (License is in README)
+ install -Dm644 $pkgname/LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+
+ # Install binary
+ install -Dm755 $pkgname/mo "${pkgdir}/usr/bin/mo"
+}