summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlukelabrie2023-05-15 14:59:28 +0200
committerlukelabrie2023-05-15 14:59:28 +0200
commit3ef5480ff1bdbf5c5e4c5a639f5d676510975ea9 (patch)
treec337d1379a9b63a95245feb48733b391c83460a9
parent9350e083938f1b1e83c63af5b08074244ff00eac (diff)
downloadaur-3ef5480ff1bdbf5c5e4c5a639f5d676510975ea9.tar.gz
add patch to source array and add moab-git as conflict
-rwxr-xr-xPKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 514bf313297d..6408cd29413b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,11 +25,12 @@ makedepends=(
)
provides=("${pkgname%-pkgver}")
-source=('https://ftp.mcs.anl.gov/pub/fathom/moab-5.3.0.tar.gz')
-md5sums=('7ae3967f297f7d6fddf38de576e98758')
+conflicts=(moab-git)
+source=('https://ftp.mcs.anl.gov/pub/fathom/moab-5.3.0.tar.gz' 'moab-5.3.0-p.1.patch')
+md5sums=('7ae3967f297f7d6fddf38de576e98758' 'SKIP')
prepare() {
cd "$pkgname-$pkgver"
-patch --forward --input="../../moab-5.3.0-p.1.patch"
+patch --forward --input="${srcdir}/moab-5.3.0-p.1.patch"
}
build() {
cd $srcdir