summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlukelabrie2023-02-21 11:17:17 +0100
committerlukelabrie2023-02-21 11:17:17 +0100
commit653365e998eb14334f17036a3c3b58beaf4c3a3f (patch)
treef6afc0131e8a1804f1c8bb6db543bbebed66b2ff
parenta5206dbcadb38c02c45c25695a9ea8a4b515651e (diff)
downloadaur-653365e998eb14334f17036a3c3b58beaf4c3a3f.tar.gz
try version 5.4.0 to avoid manual pyMOAB install
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05b894280555..0cdff971c44d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = moab
pkgdesc = The Mesh-Oriented datABase MOAB is a component for representing and evaluating mesh data
- pkgver = 5.3.1
+ pkgver = 5.4.0
pkgrel = 1
url = https://bitbucket.org/fathomteam/moab
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = moab
depends = blas
depends = lapack
provides = moab
- source = http://ftp.mcs.anl.gov/pub/fathom/moab-5.3.1.tar.gz
+ source = https://ftp.mcs.anl.gov/pub/fathom/moab-5.4.0.tar.gz
md5sums = 935d18f8edf7dc3df625d9426a2d59e1
pkgname = moab
diff --git a/PKGBUILD b/PKGBUILD
index 08673985c466..4a58a61350f7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Luke Labrie-Cleary <luke dot cleary at copenhagenatomics dot com>
pkgname=moab
-pkgver=5.3.1
+pkgver=5.4.0
pkgrel=1
pkgdesc="The Mesh-Oriented datABase MOAB is a component for representing and evaluating mesh data"
arch=('x86_64')
@@ -24,7 +24,7 @@ makedepends=(
)
provides=("${pkgname%-pkgver}")
-source=('http://ftp.mcs.anl.gov/pub/fathom/moab-5.3.1.tar.gz')
+source=('https://ftp.mcs.anl.gov/pub/fathom/moab-5.4.0.tar.gz')
md5sums=('935d18f8edf7dc3df625d9426a2d59e1')
build() {
@@ -36,15 +36,14 @@ build() {
-DENABLE_BLASLAPACK=OFF \
-DENABLE_PYMOAB=ON \
-DBUILD_SHARED_LIBS=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/MOAB \
- -DCMAKE_INSTALL_FULL_LIBDIR=${pkgdir}/opt/MOAB
+ -DCMAKE_INSTALL_PREFIX=/opt/MOAB
make
}
package() {
cd $srcdir/build
make DESTDIR="$pkgdir/" install
- cd pymoab
- bash install.sh
- python setup.py install --user
+ # cd pymoab
+ # bash install.sh
+ # python setup.py install --user
}