summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:56:12 +0200
committeroli2015-06-12 21:56:12 +0200
commitf3dbbfde32ef66b52323c168bbdaac8017f81102 (patch)
tree5714c6556b8e47f1dc160e06694e5ca1e52a2cd4
downloadaur-f3dbbfde32ef66b52323c168bbdaac8017f81102.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD54
-rw-r--r--directories.ini38
-rw-r--r--mobac.desktop7
4 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b8c64859cfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mobac-svn
+ pkgdesc = application that creates atlases for the J2ME application TrekBuddy
+ pkgver = 2021
+ pkgrel = 1
+ url = http://mobac.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = apache-ant
+ makedepends = sed
+ makedepends = subversion
+ makedepends = java-environment
+ depends = java-runtime
+ provides = mobac
+ conflicts = mobac
+ source = mobac.desktop
+ source = directories.ini
+ md5sums = 78a831bdc101f859138700f7e61ff148
+ md5sums = eacac8afe131dda257e5d3dfff6c6ac5
+
+pkgname = mobac-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df7f38b4f073
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=mobac-svn
+pkgver=2021
+pkgrel=1
+pkgdesc="application that creates atlases for the J2ME application TrekBuddy"
+arch=('i686' 'x86_64')
+url="http://mobac.sourceforge.net/"
+license=('GPL')
+depends=('java-runtime')
+makedepends=('apache-ant' 'sed' 'subversion' 'java-environment')
+source=('mobac.desktop' 'directories.ini')
+md5sums=('78a831bdc101f859138700f7e61ff148'
+ 'eacac8afe131dda257e5d3dfff6c6ac5')
+
+provides=('mobac')
+conflicts=('mobac')
+
+_svntrunk="http://svn.code.sf.net/p/mobac/code/trunk/"
+_svnmod="mobac"
+
+build() {
+ cd $srcdir/
+
+ # get the sources
+ msg "Connecting to $_svntrunk ..."
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up) || return 1
+ else
+ svn co $_svntrunk $_svnmod || return 1
+ fi
+ msg "SVN checkout done or server timeout"
+
+ cd $_svnmod
+
+ cd $srcdir/mobac/MOBAC
+ ant || /usr/share/java/apache-ant/bin/ant
+}
+
+package() {
+ cd $srcdir/mobac/MOBAC
+ mkdir -p $pkgdir/usr/share/mobac/mapsources
+ install -Dm 644 ./Mobile_Atlas_Creator.jar $pkgdir/usr/share/mobac/Mobile_Atlas_Creator.jar
+ install -Dm 644 ./README.HTM $pkgdir/usr/share/mobac/README.html
+ install -Dm 644 ./CHANGELOG.txt $pkgdir/usr/share/mobac/CHANGELOG.txt
+ install -Dm 644 ./gpl.txt $pkgdir/usr/share/mobac/gpl.txt
+ # we need to supply the full path to starting script
+ /usr/bin/sed "s/Mobile_Atlas_Creator.jar/\/usr\/share\/mobac\/Mobile_Atlas_Creator.jar/" ./start.sh >./mobac
+ install -Dm 755 ./mobac $pkgdir/usr/bin/mobac
+ install -Dm 644 ../website/images/logo3.png $pkgdir/usr/share/pixmaps/mobac.png
+ install -Dm 644 $srcdir/mobac.desktop $pkgdir/usr/share/applications/mobac.desktop
+ install -Dm 644 $srcdir/directories.ini $pkgdir/usr/share/mobac/directories.ini
+ find $srcdir/mobac/MOBAC/mapsources -maxdepth 1 -type f -name "*jar" -exec cp '{}' $pkgdir/usr/share/mobac/mapsources \;
+}
diff --git a/directories.ini b/directories.ini
new file mode 100644
index 000000000000..0f2c6dad1406
--- /dev/null
+++ b/directories.ini
@@ -0,0 +1,38 @@
+################################################
+# MOBAC system wide directory configuration
+################################################
+#
+# For activating this configuration file rename it to "directories.ini"
+# (remove the .template extension) and place it in the same directory as
+# the file Mobile_Atlas_Creator.jar
+#
+# Available variables:
+#
+# ${home}
+# user home directory, e.g. /home/username/ on Linux or C:\Users\username\ on Win Vista/7
+#
+# ${mobac-prog}
+# directory where MOBAC (or to be detailed Mobile_Atlas_Creator.jar) has been installed into
+#
+# Notes:
+# On Windows you have to use slashes "/" instead of back-slashes "\" e.g. C:/temp/mobac
+# Absolute pathes are also valid
+
+#Uncomment one of the following lines starting with "mobac." for redefining the directory
+
+# Directory where to save settings.xml and serach for log4j.xml
+mobac.usersettingsdir=${home}/.mobac
+#mobac.usersettingsdir=D:/MOBAC
+
+# Directory where to save and load atlas profiles
+#mobac.atlasprofilesdir=${home}/.mobac
+
+# Directory where to search "map packs", custom maps and beanShell map sources
+# Updated map packs are also saved into this directory overwriting old ones
+#mobac.mapsourcesdir=${mobac-prog}/mapsources
+
+# Directory where to create the cache databases of downloaded tiles
+mobac.tilestoredir=${home}/.mobac/tilestore
+
+# Directory where to create the temporary download container
+mobac.tmpdir=/tmp
diff --git a/mobac.desktop b/mobac.desktop
new file mode 100644
index 000000000000..d71418b004e8
--- /dev/null
+++ b/mobac.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Mobile Atlas Creator
+Comment=Offline atlas creator for GPS handhels and cell phone applications
+Exec=mobac
+Icon=mobac
+Categories=Education;Geography;