summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-14 01:59:19 +0300
committerDimitris Kiziridis2020-05-14 01:59:19 +0300
commitb2967d853f1a463691dfaf605f0319f8a03eb5ee (patch)
tree3b6f7fff74641178f0d4d5e08e93a1726c6f4d1a
parent77ed456d66bea415d99c12df61d3fb6d79548672 (diff)
downloadaur-b2967d853f1a463691dfaf605f0319f8a03eb5ee.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d41dd905136..9867f6044af1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,10 @@ pkgbase = mobicon-cli
arch = any
license = MIT
makedepends = npm
- noextract = v3.0.0.tar.gz
- source = https://github.com/SamVerschueren/mobicon-cli/archive/v3.0.0.tar.gz
- md5sums = f1e62e5c65da7214c52160b5bd52296c
+ depends = nodejs
+ noextract = mobicon-cli-3.0.0.tar.gz
+ source = mobicon-cli-3.0.0.tar.gz::https://github.com/SamVerschueren/mobicon-cli/archive/v3.0.0.tar.gz
+ sha256sums = 6a067aab4fdfebe1ed357a41e7b612da808cd5a1b24733d088336aaed79ed12b
pkgname = mobicon-cli
diff --git a/PKGBUILD b/PKGBUILD
index daeb27809e41..0f462930902e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,14 @@ pkgdesc="Mobile icon generator"
arch=('any')
url='https://github.com/SamVerschueren/mobicon-cli'
license=('MIT')
+depends=('nodejs')
makedepends=('npm')
-noextract=("v${pkgver}.tar.gz")
-source=("${url}/archive/v${pkgver}.tar.gz")
-md5sums=('f1e62e5c65da7214c52160b5bd52296c')
+noextract=("${pkgname}-${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('6a067aab4fdfebe1ed357a41e7b612da808cd5a1b24733d088336aaed79ed12b')
package() {
- npm install -g --user root --prefix "${pkgdir}/usr" "${srcdir}/v${pkgver}.tar.gz"
+ npm install -g --user root --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tar.gz"
find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
local tmppackage="$(mktemp)"
local pkgjson="$pkgdir/usr/lib/node_modules/$pkgname/package.json"
@@ -22,4 +23,5 @@ package() {
chmod 644 "$pkgjson"
find "${pkgdir}/usr" -type d -exec chmod 755 {} +
chown -R root:root "${pkgdir}"
+ install -Dm644 "${pkgdir}//usr/lib/node_modules/mobicon-cli/license" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file