summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Drechsler2021-01-04 19:31:33 +0100
committerPatrick Drechsler2021-01-04 19:31:33 +0100
commit37f03c3fef1b91050914f410ed6a3d79ccdde819 (patch)
tree253471cd403588e152e3b6e6e6224b805bf2cfcb
downloadaur-37f03c3fef1b91050914f410ed6a3d79ccdde819.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0816b62b0506
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mobsh
+ pkgdesc = Swift git handover
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/remotemobprogramming/mob
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = git
+ optdepends = espeak-ng-espeak: Multi-lingual software speech synthesizer
+ optdepends = mbrola-voices-us1: An American English female voice for the MBROLA synthesizer
+ provides = mobsh
+ conflicts = mobsh
+ conflicts = mob
+ source = https://github.com/remotemobprogramming/mob/archive/v1.1.0.tar.gz
+ sha256sums = 4e65f2eef137c782a0c5bd7cba39c44f0dd322af3b1d0b3723f3938de3ab1646
+
+pkgname = mobsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3bd7069efa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Patrick Drechsler <socialcoding at pdrechsler dot de>
+
+pkgname=mobsh
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Swift git handover"
+arch=('x86_64')
+url="https://github.com/remotemobprogramming/mob"
+license=('MIT')
+depends=("git")
+optdepends=('espeak-ng-espeak: Multi-lingual software speech synthesizer'
+ 'mbrola-voices-us1: An American English female voice for the MBROLA synthesizer')
+makedepends=('go')
+provides=('mobsh')
+conflicts=('mobsh' 'mob')
+source=("$url/archive/v${pkgver}.tar.gz")
+sha256sums=('4e65f2eef137c782a0c5bd7cba39c44f0dd322af3b1d0b3723f3938de3ab1646')
+
+prepare(){
+ cd "mob-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "mob-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build mob.go
+}
+
+check() {
+ cd "mob-$pkgver"
+ ./create-testbed
+ go test
+}
+
+package() {
+ cd "mob-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 build/mob "$pkgdir"/usr/bin/mob
+}