summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Drechsler2021-01-04 11:15:33 +0100
committerPatrick Drechsler2021-01-04 11:15:33 +0100
commit3b456572ee89e0fa9157a44afa6690f6ed3b76ea (patch)
treea5b3e7e6d41d329d4600e561177a6136c121fb02
parent2500b12b11599046b81e499febf082ad4de3c522 (diff)
downloadaur-3b456572ee89e0fa9157a44afa6690f6ed3b76ea.tar.gz
split sources and rename license file
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 032547715d4e..89b632a6bac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mobsh-bin
- pkgdesc = Swift git handover with mob
+ pkgdesc = Swift git handover
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/remotemobprogramming/mob
arch = x86_64
license = MIT
@@ -11,10 +11,10 @@ pkgbase = mobsh-bin
provides = mobsh
conflicts = mobsh
conflicts = mob
- source = https://github.com/remotemobprogramming/mob/releases/download/v1.1.0/mob_v1.1.0_linux_amd64.tar.gz
- source = https://raw.githubusercontent.com/remotemobprogramming/mob/master/LICENSE
- md5sums = 32ae7ffd2b8f5705e8242fc9bcf1a553
+ source = mobsh-bin-1.1.0-LICENSE::https://github.com/remotemobprogramming/mob/raw/v1.1.0/LICENSE
md5sums = d449b361903e8abd9b9ee977bfa5d966
+ source_x86_64 = https://github.com/remotemobprogramming/mob/releases/download/v1.1.0/mob_v1.1.0_linux_amd64.tar.gz
+ md5sums_x86_64 = 32ae7ffd2b8f5705e8242fc9bcf1a553
pkgname = mobsh-bin
diff --git a/PKGBUILD b/PKGBUILD
index dd8a13fb2451..fcf1bc0b1d3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=mobsh-bin
pkgver=1.1.0
-pkgrel=1
-pkgdesc="Swift git handover with mob"
+pkgrel=2
+pkgdesc="Swift git handover"
arch=('x86_64')
url="https://github.com/remotemobprogramming/mob"
license=('MIT')
@@ -13,12 +13,12 @@ optdepends=('espeak-ng-espeak: Multi-lingual software speech synthesizer'
provides=('mobsh')
conflicts=('mobsh' 'mob')
-source=("$url/releases/download/v${pkgver}/mob_v${pkgver}_linux_amd64.tar.gz"
- "https://raw.githubusercontent.com/remotemobprogramming/mob/master/LICENSE")
-md5sums=("32ae7ffd2b8f5705e8242fc9bcf1a553"
- "d449b361903e8abd9b9ee977bfa5d966")
+source_x86_64=("$url/releases/download/v${pkgver}/mob_v${pkgver}_linux_amd64.tar.gz")
+md5sums_x86_64=("32ae7ffd2b8f5705e8242fc9bcf1a553")
+source=("${pkgname}-${pkgver}-LICENSE::${url}/raw/v${pkgver}/LICENSE")
+md5sums=("d449b361903e8abd9b9ee977bfa5d966")
package() {
- install -D -m644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "$pkgname-$pkgver-LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D -m755 "mob" "$pkgdir/usr/bin/mob"
}