summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreizh2018-10-18 23:16:58 +0200
committerBreizh2018-10-18 23:16:58 +0200
commit744625e973ecba59187efd89f3268ed80ce114b2 (patch)
treec321d86eca3ad7760771878216b6d6914893764f
downloadaur-744625e973ecba59187efd89f3268ed80ce114b2.tar.gz
Initial commit
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD53
-rw-r--r--moc-ffmpeg4.patch33
-rw-r--r--moc-https.patch10
4 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e774c9b136bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = moc-https
+ pkgdesc = MOC with a patch to listen HTTPS streams
+ pkgver = 2.5.2
+ pkgrel = 2
+ epoch = 1
+ url = http://moc.daper.net/
+ arch = x86_64
+ license = GPL
+ makedepends = speex
+ makedepends = ffmpeg
+ makedepends = taglib
+ makedepends = libmpcdec
+ makedepends = wavpack
+ makedepends = libmodplug
+ makedepends = faad2
+ depends = libmad
+ depends = libid3tag
+ depends = jack
+ depends = curl
+ depends = libltdl
+ depends = file
+ optdepends = speex: for using the speex plugin
+ optdepends = ffmpeg: for using the ffmpeg plugin
+ optdepends = taglib: for using the musepack plugin
+ optdepends = libmpcdec: for using the musepack plugin
+ optdepends = wavpack: for using the wavpack plugin
+ optdepends = faad2: for using the aac plugin
+ optdepends = libmodplug: for using the modplug plugin
+ provides = moc
+ conflicts = moc
+ source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2
+ source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2.sig
+ source = moc-ffmpeg4.patch
+ source = moc-https.patch
+ validpgpkeys = 59359B80406D9E73E80599BEF3121E4F2885A7AA
+ sha1sums = 9d27a929b63099416263471c16367997c0ae6dba
+ sha1sums = SKIP
+ sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
+ sha1sums = edb02778aa1eebf9f843b202bb2517b8e10f3029
+
+pkgname = moc-https
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12aad5c97c6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Breizh <breizh@breizh.me>
+# Contributor: Eric Bélanger <eric@archlinux.org>
+
+pkgname=moc-https
+_pkgname=moc
+pkgver=2.5.2
+pkgrel=2
+epoch=1
+pkgdesc="An ncurses console audio player with HTTPS stream support"
+arch=('x86_64')
+url="http://moc.daper.net/"
+license=('GPL')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
+makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
+optdepends=('speex: for using the speex plugin'
+ 'ffmpeg: for using the ffmpeg plugin'
+ 'taglib: for using the musepack plugin'
+ 'libmpcdec: for using the musepack plugin'
+ 'wavpack: for using the wavpack plugin'
+ 'faad2: for using the aac plugin'
+ 'libmodplug: for using the modplug plugin')
+provides=('moc')
+conflicts=('moc')
+source=(http://ftp.daper.net/pub/soft/moc/stable/${_pkgname}-${pkgver}.tar.bz2{,.sig}
+ moc-ffmpeg4.patch
+ moc-https.patch)
+
+sha1sums=('9d27a929b63099416263471c16367997c0ae6dba'
+ 'SKIP'
+ '007a0580ac754e1c318a0d0b6f0d403883797eaf'
+ 'edb02778aa1eebf9f843b202bb2517b8e10f3029')
+validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p0 -i ../moc-ffmpeg4.patch # Fix build with ffmpeg 4 (taken from official release on ArchLinux)
+ patch -p0 -i ../moc-https.patch # Fix HTTPS streams
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --without-rcc \
+ --with-oss --with-alsa --with-jack --with-aac --with-mp3 \
+ --with-musepack --with-vorbis --with-flac --with-wavpack \
+ --with-sndfile --with-modplug --with-ffmpeg --with-speex \
+ --with-samplerate --with-curl --disable-cache --disable-debug
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/moc-ffmpeg4.patch b/moc-ffmpeg4.patch
new file mode 100644
index 000000000000..c1e43a7c2f3e
--- /dev/null
+++ b/moc-ffmpeg4.patch
@@ -0,0 +1,33 @@
+Index: decoder_plugins/ffmpeg/ffmpeg.c
+===================================================================
+--- decoder_plugins/ffmpeg/ffmpeg.c (revisión: 2963)
++++ decoder_plugins/ffmpeg/ffmpeg.c (copia de trabajo)
+@@ -697,7 +697,7 @@
+ * FFmpeg/LibAV in use. For some versions this will be caught in
+ * *_find_stream_info() above and misreported as an unfound codec
+ * parameters error. */
+- if (data->codec->capabilities & CODEC_CAP_EXPERIMENTAL) {
++ if (data->codec->capabilities & AV_CODEC_CAP_EXPERIMENTAL) {
+ decoder_error (&data->error, ERROR_FATAL, 0,
+ "The codec is experimental and may damage MOC: %s",
+ data->codec->name);
+@@ -705,8 +705,8 @@
+ }
+
+ set_downmixing (data);
+- if (data->codec->capabilities & CODEC_CAP_TRUNCATED)
+- data->enc->flags |= CODEC_FLAG_TRUNCATED;
++ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
++ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
+
+ if (avcodec_open2 (data->enc, data->codec, NULL) < 0)
+ {
+@@ -725,7 +725,7 @@
+
+ data->sample_width = sfmt_Bps (data->fmt);
+
+- if (data->codec->capabilities & CODEC_CAP_DELAY)
++ if (data->codec->capabilities & AV_CODEC_CAP_DELAY)
+ data->delay = true;
+ data->seek_broken = is_seek_broken (data);
+ data->timing_broken = is_timing_broken (data->ic);
diff --git a/moc-https.patch b/moc-https.patch
new file mode 100644
index 000000000000..143e4f16a484
--- /dev/null
+++ b/moc-https.patch
@@ -0,0 +1,10 @@
+--- files.c 2016-11-16 01:54:37.000000000 +0100
++++ /tmp/files.c 2018-10-12 11:34:55.297373063 +0200
+@@ -93,6 +93,7 @@
+ inline int is_url (const char *str)
+ {
+ return !strncasecmp (str, "http://", sizeof ("http://") - 1)
++ || !strncasecmp (str, "https://", sizeof ("https://") - 1)
+ || !strncasecmp (str, "ftp://", sizeof ("ftp://") - 1);
+ }
+