summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-10-24 00:59:57 +0300
committerChristoph Gysin2015-10-24 00:59:57 +0300
commitc35a6f09affce5b40d89a8eac5f6914aa7b132b3 (patch)
tree16fe25d45ad9cbbe79a331f1418a49274e198570
downloadaur-c35a6f09affce5b40d89a8eac5f6914aa7b132b3.tar.gz
initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD65
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5d2083444ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = moc-lyrics-git
+ pkgdesc = An ncurses console audio player (with lyrics patch)
+ pkgver = 1
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/christophgysin/moc
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = speex
+ makedepends = ffmpeg
+ makedepends = taglib
+ makedepends = libmpcdec
+ makedepends = wavpack
+ makedepends = libmodplug
+ makedepends = faad2
+ depends = libmad
+ depends = libid3tag
+ depends = jack
+ depends = curl
+ depends = libltdl
+ depends = file
+ optdepends = speex: for using the speex plugin
+ optdepends = ffmpeg: for using the ffmpeg plugin
+ optdepends = taglib: for using the musepack plugin
+ optdepends = libmpcdec: for using the musepack plugin
+ optdepends = wavpack: for using the wavpack plugin
+ optdepends = faad2: for using the aac plugin
+ optdepends = libmodplug: for using the modplug plugin
+ provides = moc
+ source = git+https://github.com/christophgysin/moc#branch=lyrics
+ sha1sums = SKIP
+
+pkgname = moc-lyrics-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..032081f141b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.tar.*
+/moc/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e4d3b235fab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+
+pkgname=moc-lyrics-git
+_pkgname=moc
+pkgver=7c57de0
+pkgrel=1
+epoch=1
+pkgdesc="An ncurses console audio player (with lyrics patch)"
+arch=('i686' 'x86_64')
+url="https://github.com/christophgysin/moc"
+license=('GPL')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
+makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
+optdepends=('speex: for using the speex plugin'
+ 'ffmpeg: for using the ffmpeg plugin'
+ 'taglib: for using the musepack plugin'
+ 'libmpcdec: for using the musepack plugin'
+ 'wavpack: for using the wavpack plugin'
+ 'faad2: for using the aac plugin'
+ 'libmodplug: for using the modplug plugin')
+provides=('moc')
+conflicts=('moc')
+source=('git+https://github.com/christophgysin/moc#branch=lyrics')
+sha1sums=('SKIP')
+
+pkgver()
+{
+ cd $_pkgname
+ git describe --always --long | sed -r "s/^$_pkgname-//;s/([^-]*-g)/r\\1/;s/-/./g"
+}
+
+build()
+{
+ cd $_pkgname
+ autoreconf -ifs
+ ./configure \
+ --prefix=/usr \
+ --without-rcc \
+ --with-oss \
+ --with-alsa \
+ --with-jack \
+ --with-aac \
+ --with-mp3 \
+ --with-musepack \
+ --with-vorbis \
+ --with-flac \
+ --with-wavpack \
+ --with-sndfile \
+ --with-modplug \
+ --with-ffmpeg \
+ --with-speex \
+ --with-samplerate \
+ --with-curl \
+ --disable-cache \
+ --disable-debug
+ make
+}
+
+package()
+{
+ cd $_pkgname
+ make \
+ DESTDIR="${pkgdir}" \
+ install
+}