summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-09-02 16:10:03 +0100
committerHans-Nikolai Viessmann2016-09-02 16:10:03 +0100
commit46067d1519e18f8d98d9ef436bcf9ad358cdbeb1 (patch)
tree2e6d9fc8f5f4a8e181d6e15fd490e383c75d0e52
parent02a3d78cc55873f5e01a22ca8f08c67a0ca8af66 (diff)
downloadaur-46067d1519e18f8d98d9ef436bcf9ad358cdbeb1.tar.gz
Updated to version 2.5.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--moc-ffmpeg3.patch102
3 files changed, 12 insertions, 117 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f75eafdb1dc..b1a3c4537930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = moc-pulse
pkgdesc = An ncurses console audio player with support for pulseaudio
- pkgver = 2.5.0
+ pkgver = 2.5.1
pkgrel = 1
url = http://moc.daper.net/
arch = i686
@@ -29,14 +29,12 @@ pkgbase = moc-pulse
optdepends = libmodplug: for using the modplug plugin
provides = moc
conflicts = moc
- source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.0.tar.bz2
- source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.0.tar.bz2.sig
- source = moc-ffmpeg3.patch
+ source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.1.tar.bz2
+ source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.1.tar.bz2.sig
source = pulseaudio.patch
validpgpkeys = 59359B80406D9E73E80599BEF3121E4F2885A7AA
- sha1sums = a02c10075541995771dbdccb7f2d0ecd19d70b81
+ sha1sums = 9e9a9bf0260cd7d7c170e4ef957041cf2275de32
sha1sums = SKIP
- sha1sums = 7d997ac25041010837d5f3ec79920b8afeec87f7
sha1sums = 5c6385760ba40ee8a330d28d520c44eac2cbbae1
pkgname = moc-pulse
diff --git a/PKGBUILD b/PKGBUILD
index 953f52292bdb..4f2a7e90f591 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname='moc-pulse'
_pkgname='moc'
-pkgver=2.5.0
+pkgver=2.5.1
pkgrel=1
pkgdesc='An ncurses console audio player with support for pulseaudio'
arch=('i686' 'x86_64')
@@ -23,28 +23,27 @@ optdepends=('speex: for using the speex plugin'
provides=('moc')
conflicts=('moc')
source=(http://ftp.daper.net/pub/soft/moc/stable/${_pkgname}-${pkgver}.tar.bz2{,.sig}
- 'moc-ffmpeg3.patch'
'pulseaudio.patch')
-sha1sums=('a02c10075541995771dbdccb7f2d0ecd19d70b81'
+sha1sums=('9e9a9bf0260cd7d7c170e4ef957041cf2275de32'
'SKIP'
- '7d997ac25041010837d5f3ec79920b8afeec87f7'
'5c6385760ba40ee8a330d28d520c44eac2cbbae1')
validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
prepare() {
cd "${_pkgname}-${pkgver}"
-# Add pulseaudio backend
+ # Add pulseaudio backend
patch -p1 -i ../pulseaudio.patch
-
-# Fix build with ffmpeg 3.0 (Debian)
- patch -p1 -i ../moc-ffmpeg3.patch
}
build() {
cd "${_pkgname}-${pkgver}"
+
+ msg "Re-creating ./configure script"
aclocal
automake --add-missing
autoreconf
+
+ msg "Begin configuring"
./configure --prefix=/usr --without-rcc \
--with-pulse --with-oss --with-alsa --with-jack --with-aac \
--with-mp3 --with-musepack --with-vorbis --with-flac \
@@ -59,4 +58,4 @@ package() {
make DESTDIR="${pkgdir}" install
}
-# vim:ts=4 sw=4
+# vim: ts=2 sw=2
diff --git a/moc-ffmpeg3.patch b/moc-ffmpeg3.patch
deleted file mode 100644
index 0d872d704b80..000000000000
--- a/moc-ffmpeg3.patch
+++ /dev/null
@@ -1,102 +0,0 @@
---- moc-2.5.0.orig/configure.in
-+++ moc-2.5.0/configure.in
-@@ -557,22 +557,6 @@ then
- echo
- fi
-
--dnl
--dnl If the warning below gets reported, then for further guidance:
--dnl
--dnl vi +/REQUEST_CHANNELS decoder_plugins/ffmpeg/ffmpeg.c
--dnl
--if test "x$want_ffmpeg" = "xyes" && \
-- test "x$ac_cv_member_struct_AVCodecContext_request_channels" != "xyes"
--then
-- echo "WARNING: It appears that the FFmpeg/LibAV API has changed and no longer"
-- echo " supports downmixing to stereo as it did previously. Report"
-- echo " this message along with the output of 'ffmpeg -version' to"
-- echo " <$PACKAGE_BUGREPORT>. Meanwhile, you may have to live without"
-- echo " stereo downmixing."
-- echo
--fi
--
- echo "WARNING: Since MOC version 2 the executable file name has changed to mocp!"
- echo " Please remove old moc binary if you have installed an older version."
- echo
---- moc-2.5.0.orig/decoder_plugins/ffmpeg/ffmpeg.c
-+++ moc-2.5.0/decoder_plugins/ffmpeg/ffmpeg.c
-@@ -67,7 +67,7 @@ GCC_DIAG_OFF(deprecated-declarations)
- GCC_DIAG_ON(deprecated-declarations)
- #include <libavutil/mathematics.h>
- #ifdef HAVE_AV_GET_CHANNEL_LAYOUT_NB_CHANNELS
--#include <libavutil/audioconvert.h>
-+#include <libavutil/channel_layout.h>
- #endif
- #else
- #include <ffmpeg/avformat.h>
-@@ -823,17 +823,6 @@ static bool is_seek_broken (struct ffmpe
- return false;
- }
-
--#ifdef HAVE_STRUCT_AVCODECCONTEXT_REQUEST_CHANNELS
--/* This warning reset suppresses a deprecation warning message
-- * for the AVCodecContext's 'request_channels' field. */
--GCC_DIAG_OFF(deprecated-declarations)
--static inline void set_request_channels (AVCodecContext *enc, int channels)
--{
-- enc->request_channels = channels;
--}
--GCC_DIAG_ON(deprecated-declarations)
--#endif
--
- /* Downmix multi-channel audios to stereo. */
- static void set_downmixing (struct ffmpeg_data *data)
- {
-@@ -847,30 +836,11 @@ static void set_downmixing (struct ffmpe
-
- data->enc->channels = 2;
-
--#ifdef HAVE_STRUCT_AVCODECCONTEXT_REQUEST_CHANNELS
--
-- /*
-- * When FFmpeg breaks its API (and it will), this code will be
-- * disabled and users will complain that MOC no longer downmixes
-- * to stereo. This is because the 'request_channels' field in
-- * AVCodecContext is marked as deprecated (and so will probably
-- * be removed at some time) but FFmpeg requires it to be set to
-- * trigger downmixing (go figure!). Currently, there is no
-- * guidance on how it will work in the future, but looking at
-- * where 's->downmixed' is set near the end of 'ac3_decode_init()'
-- * in the FFmpeg's source code file 'libavcodec/ac3dec.c' might
-- * help (in the absence of proper documentation).
-- */
--
-- set_request_channels (data->enc, 2);
--
- #ifdef AV_CH_LAYOUT_STEREO_DOWNMIX
- data->enc->request_channel_layout = AV_CH_LAYOUT_STEREO_DOWNMIX;
- #else
- data->enc->request_channel_layout = CH_LAYOUT_STEREO_DOWNMIX;
- #endif
--
--#endif
- }
-
- static void *ffmpeg_open (const char *file)
---- moc-2.5.0.orig/decoder_plugins/ffmpeg/ffmpeg.m4
-+++ moc-2.5.0/decoder_plugins/ffmpeg/ffmpeg.m4
-@@ -51,14 +51,6 @@ then
- save_LIBS="$LIBS"
- LIBS="$LIBS $ffmpeg_LIBS"
- AC_CHECK_HEADERS(ffmpeg/avformat.h libavformat/avformat.h)
-- if test "x$ac_cv_header_ffmpeg_avformat_h" = "xyes"
-- then
-- AC_CHECK_MEMBERS([struct AVCodecContext.request_channels], [], [],
-- [#include <ffmpeg/avcodec.h>])
-- else
-- AC_CHECK_MEMBERS([struct AVCodecContext.request_channels], [], [],
-- [#include <libavcodec/avcodec.h>])
-- fi
- AC_SEARCH_LIBS(avcodec_open2, avcodec,
- [AC_DEFINE([HAVE_AVCODEC_OPEN2], 1,
- [Define to 1 if you have the `avcodec_open2' function.])])