summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2020-11-19 11:39:59 +0100
committerHans-Nikolai Viessmann2020-11-19 11:39:59 +0100
commit4ac61c7035d02fd86c9560b69e2fea762d6c596c (patch)
tree19795e4325b4dcc8e006282e0e78c0f3821a1a16
parent5e81de3d989b03e0b424719aea168c0789af8206 (diff)
downloadaur-4ac61c7035d02fd86c9560b69e2fea762d6c596c.tar.gz
add https patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--moc-https.patch10
3 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c981ee590629..4052cca1ed0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = moc-pulse
pkgdesc = An ncurses console audio player with support for pulseaudio
pkgver = 2.5.2
- pkgrel = 2
- url = http://moc.daper.net/
+ pkgrel = 3
+ url = https://moc.daper.net/
arch = x86_64
license = GPL
makedepends = speex
@@ -32,11 +32,13 @@ pkgbase = moc-pulse
source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2.sig
source = pulseaudio.patch
source = moc-ffmpeg4.patch
+ source = moc-https.patch
validpgpkeys = 59359B80406D9E73E80599BEF3121E4F2885A7AA
sha1sums = 9d27a929b63099416263471c16367997c0ae6dba
sha1sums = SKIP
sha1sums = 5c6385760ba40ee8a330d28d520c44eac2cbbae1
sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
+ sha1sums = e3362ddd41126e2be874cd372a053fdaccf0f616
pkgname = moc-pulse
diff --git a/PKGBUILD b/PKGBUILD
index 4862159dbb5c..2b8048402e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
# Contributor: Vladimir Protasov <eoranged@ya.ru>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
@@ -6,35 +5,39 @@
pkgname='moc-pulse'
_pkgname='moc'
pkgver=2.5.2
-pkgrel=2
+pkgrel=3
pkgdesc='An ncurses console audio player with support for pulseaudio'
arch=('x86_64')
-url="http://moc.daper.net/"
+url="https://moc.daper.net/"
license=('GPL')
depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'pulseaudio')
makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
optdepends=('speex: for using the speex plugin'
- 'ffmpeg: for using the ffmpeg plugin'
- 'taglib: for using the musepack plugin'
- 'libmpcdec: for using the musepack plugin'
+ 'ffmpeg: for using the ffmpeg plugin'
+ 'taglib: for using the musepack plugin'
+ 'libmpcdec: for using the musepack plugin'
'wavpack: for using the wavpack plugin'
'faad2: for using the aac plugin'
- 'libmodplug: for using the modplug plugin')
+ 'libmodplug: for using the modplug plugin')
provides=('moc')
conflicts=('moc')
source=(http://ftp.daper.net/pub/soft/moc/stable/${_pkgname}-${pkgver}.tar.bz2{,.sig}
'pulseaudio.patch'
- 'moc-ffmpeg4.patch')
+ 'moc-ffmpeg4.patch'
+ 'moc-https.patch')
sha1sums=('9d27a929b63099416263471c16367997c0ae6dba'
'SKIP'
'5c6385760ba40ee8a330d28d520c44eac2cbbae1'
- '007a0580ac754e1c318a0d0b6f0d403883797eaf')
+ '007a0580ac754e1c318a0d0b6f0d403883797eaf'
+ 'e3362ddd41126e2be874cd372a053fdaccf0f616')
validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
prepare() {
cd "${_pkgname}-${pkgver}"
# Fix build with ffmpeg 4 (taken from official release on ArchLinux)
patch -p0 -i ../moc-ffmpeg4.patch
+ # Allow https for urls https://moc.daper.net/node/1872 (taken from official release on ArchLinux)
+ patch -p0 -i ../moc-https.patch
# Add pulseaudio backend
patch -p1 -i ../pulseaudio.patch
}
@@ -42,12 +45,10 @@ prepare() {
build() {
cd "${_pkgname}-${pkgver}"
- msg "Re-creating ./configure script"
aclocal
automake --add-missing
autoreconf
- msg "Begin configuring"
./configure --prefix=/usr --without-rcc \
--with-pulse --with-oss --with-alsa --with-jack --with-aac \
--with-mp3 --with-musepack --with-vorbis --with-flac \
diff --git a/moc-https.patch b/moc-https.patch
new file mode 100644
index 000000000000..5ff304df944f
--- /dev/null
+++ b/moc-https.patch
@@ -0,0 +1,10 @@
+--- files.c.orig
++++ files.c
+@@ -93,6 +93,7 @@
+ inline int is_url (const char *str)
+ {
+ return !strncasecmp (str, "http://", sizeof ("http://") - 1)
++ || !strncasecmp (str, "https://", sizeof ("https://") - 1)
+ || !strncasecmp (str, "ftp://", sizeof ("ftp://") - 1);
+ }
+