summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-05-13 15:40:46 +0200
committerHans-Nikolai Viessmann2018-05-13 15:40:46 +0200
commit5e81de3d989b03e0b424719aea168c0789af8206 (patch)
tree0d0ca0f73469f5f31514b34d039b1ba63db2b8d2
parentb1dd4cdc2670a281ff743c755dad7a50ac7d035e (diff)
downloadaur-5e81de3d989b03e0b424719aea168c0789af8206.tar.gz
added FFMPEG 4.0 patch
Also dropped support for i686 as per ArchLinux changes.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--moc-ffmpeg4.patch33
3 files changed, 44 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f70fabb88cac..c981ee590629 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = moc-pulse
pkgdesc = An ncurses console audio player with support for pulseaudio
pkgver = 2.5.2
- pkgrel = 1
+ pkgrel = 2
url = http://moc.daper.net/
- arch = i686
arch = x86_64
license = GPL
makedepends = speex
@@ -32,10 +31,12 @@ pkgbase = moc-pulse
source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2
source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2.sig
source = pulseaudio.patch
+ source = moc-ffmpeg4.patch
validpgpkeys = 59359B80406D9E73E80599BEF3121E4F2885A7AA
sha1sums = 9d27a929b63099416263471c16367997c0ae6dba
sha1sums = SKIP
sha1sums = 5c6385760ba40ee8a330d28d520c44eac2cbbae1
+ sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
pkgname = moc-pulse
diff --git a/PKGBUILD b/PKGBUILD
index bc3ede299b18..4862159dbb5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
pkgname='moc-pulse'
_pkgname='moc'
pkgver=2.5.2
-pkgrel=1
+pkgrel=2
pkgdesc='An ncurses console audio player with support for pulseaudio'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://moc.daper.net/"
license=('GPL')
depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'pulseaudio')
@@ -23,14 +23,18 @@ optdepends=('speex: for using the speex plugin'
provides=('moc')
conflicts=('moc')
source=(http://ftp.daper.net/pub/soft/moc/stable/${_pkgname}-${pkgver}.tar.bz2{,.sig}
- 'pulseaudio.patch')
+ 'pulseaudio.patch'
+ 'moc-ffmpeg4.patch')
sha1sums=('9d27a929b63099416263471c16367997c0ae6dba'
'SKIP'
- '5c6385760ba40ee8a330d28d520c44eac2cbbae1')
+ '5c6385760ba40ee8a330d28d520c44eac2cbbae1'
+ '007a0580ac754e1c318a0d0b6f0d403883797eaf')
validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
prepare() {
cd "${_pkgname}-${pkgver}"
+ # Fix build with ffmpeg 4 (taken from official release on ArchLinux)
+ patch -p0 -i ../moc-ffmpeg4.patch
# Add pulseaudio backend
patch -p1 -i ../pulseaudio.patch
}
diff --git a/moc-ffmpeg4.patch b/moc-ffmpeg4.patch
new file mode 100644
index 000000000000..c1e43a7c2f3e
--- /dev/null
+++ b/moc-ffmpeg4.patch
@@ -0,0 +1,33 @@
+Index: decoder_plugins/ffmpeg/ffmpeg.c
+===================================================================
+--- decoder_plugins/ffmpeg/ffmpeg.c (revisiĆ³n: 2963)
++++ decoder_plugins/ffmpeg/ffmpeg.c (copia de trabajo)
+@@ -697,7 +697,7 @@
+ * FFmpeg/LibAV in use. For some versions this will be caught in
+ * *_find_stream_info() above and misreported as an unfound codec
+ * parameters error. */
+- if (data->codec->capabilities & CODEC_CAP_EXPERIMENTAL) {
++ if (data->codec->capabilities & AV_CODEC_CAP_EXPERIMENTAL) {
+ decoder_error (&data->error, ERROR_FATAL, 0,
+ "The codec is experimental and may damage MOC: %s",
+ data->codec->name);
+@@ -705,8 +705,8 @@
+ }
+
+ set_downmixing (data);
+- if (data->codec->capabilities & CODEC_CAP_TRUNCATED)
+- data->enc->flags |= CODEC_FLAG_TRUNCATED;
++ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
++ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
+
+ if (avcodec_open2 (data->enc, data->codec, NULL) < 0)
+ {
+@@ -725,7 +725,7 @@
+
+ data->sample_width = sfmt_Bps (data->fmt);
+
+- if (data->codec->capabilities & CODEC_CAP_DELAY)
++ if (data->codec->capabilities & AV_CODEC_CAP_DELAY)
+ data->delay = true;
+ data->seek_broken = is_seek_broken (data);
+ data->timing_broken = is_timing_broken (data->ic);