summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-09-05 12:41:03 +0200
committerHans-Nikolai Viessmann2021-09-05 12:41:03 +0200
commit73a15a413937c4848f414321932ff165911baa87 (patch)
treea8148983adca8f85f2bf136e4df53f24ea3f6006
parent4ac61c7035d02fd86c9560b69e2fea762d6c596c (diff)
downloadaur-73a15a413937c4848f414321932ff165911baa87.tar.gz
minor change to autotools reconfigure
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4052cca1ed0f..a94a040c0c81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = moc-pulse
pkgdesc = An ncurses console audio player with support for pulseaudio
pkgver = 2.5.2
- pkgrel = 3
+ pkgrel = 4
url = https://moc.daper.net/
arch = x86_64
license = GPL
@@ -41,4 +41,3 @@ pkgbase = moc-pulse
sha1sums = e3362ddd41126e2be874cd372a053fdaccf0f616
pkgname = moc-pulse
-
diff --git a/PKGBUILD b/PKGBUILD
index 2b8048402e46..d99dd70f5641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
# Contributor: Vladimir Protasov <eoranged@ya.ru>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname='moc-pulse'
_pkgname='moc'
pkgver=2.5.2
-pkgrel=3
+pkgrel=4
pkgdesc='An ncurses console audio player with support for pulseaudio'
arch=('x86_64')
url="https://moc.daper.net/"
@@ -34,21 +34,21 @@ validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
prepare() {
cd "${_pkgname}-${pkgver}"
+
# Fix build with ffmpeg 4 (taken from official release on ArchLinux)
patch -p0 -i ../moc-ffmpeg4.patch
# Allow https for urls https://moc.daper.net/node/1872 (taken from official release on ArchLinux)
patch -p0 -i ../moc-https.patch
# Add pulseaudio backend
patch -p1 -i ../pulseaudio.patch
+
+ # reconfigure the build system
+ autoreconf -i -f
}
build() {
cd "${_pkgname}-${pkgver}"
- aclocal
- automake --add-missing
- autoreconf
-
./configure --prefix=/usr --without-rcc \
--with-pulse --with-oss --with-alsa --with-jack --with-aac \
--with-mp3 --with-musepack --with-vorbis --with-flac \