summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-05-13 15:51:12 +0200
committerHans-Nikolai Viessmann2018-05-13 15:51:12 +0200
commitd19d87247fbaf750c1efed821650bcec90f4deb5 (patch)
tree8a164017b5123082cb0c51550fb3c77abac64f03
parent4f6b67ce298692ab921844f58b92cf2e84f0fa55 (diff)
downloadaur-d19d87247fbaf750c1efed821650bcec90f4deb5.tar.gz
added ffmpeg 4.0 support
Also discovered that Pulseaudio build was not even activated - oops. Minor version bump as well.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--moc-ffmpeg4.patch33
3 files changed, 49 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b9b49b6ea1e..f737c7773fe3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = moc-pulse-svn
pkgdesc = An ncurses console audio player with support for pulseaudio (SVN)
- pkgver = r2947
+ pkgver = r2963
pkgrel = 1
url = http://moc.daper.net
arch = i686
@@ -14,12 +14,14 @@ pkgbase = moc-pulse-svn
makedepends = libmodplug
makedepends = subversion
makedepends = faad2
+ makedepends = pulseaudio
depends = libmad
depends = libid3tag
depends = jack
depends = curl
depends = libltdl
depends = file
+ depends = pulseaudio
optdepends = speex: for using the speex plugin
optdepends = ffmpeg: for using the ffmpeg plugin
optdepends = taglib: for using the musepack plugin
@@ -32,8 +34,10 @@ pkgbase = moc-pulse-svn
options = !libtool
source = moc-pulse-svn::svn://daper.net/moc/trunk
source = 0001-Pulseaudio-backend.patch
+ source = moc-ffmpeg4.patch
sha1sums = SKIP
sha1sums = d86a04606eaa0960f3b59626070cd231d37b6430
+ sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
pkgname = moc-pulse-svn
diff --git a/PKGBUILD b/PKGBUILD
index 45a9dfdbc055..bb789bda3b00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
_pkgname=moc
pkgname="${_pkgname}-pulse-svn"
-pkgver=r2947
+pkgver=r2963
pkgrel=1
pkgdesc='An ncurses console audio player with support for pulseaudio (SVN)'
url='http://moc.daper.net'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'pulseaudio')
makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack'
- 'libmodplug' 'subversion' 'faad2')
+ 'libmodplug' 'subversion' 'faad2' 'pulseaudio')
optdepends=('speex: for using the speex plugin'
'ffmpeg: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
@@ -24,9 +24,11 @@ conflicts=('moc')
provides=('moc')
options=('!libtool')
source=("${pkgname}::svn://daper.net/moc/trunk"
- '0001-Pulseaudio-backend.patch')
+ '0001-Pulseaudio-backend.patch'
+ 'moc-ffmpeg4.patch')
sha1sums=('SKIP'
- 'd86a04606eaa0960f3b59626070cd231d37b6430')
+ 'd86a04606eaa0960f3b59626070cd231d37b6430'
+ '007a0580ac754e1c318a0d0b6f0d403883797eaf')
pkgver() {
cd "$srcdir/$pkgname"
@@ -36,6 +38,9 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
+ # Fix build with ffmpeg 4 (taken from official release on ArchLinux)
+ patch -p0 -i ../moc-ffmpeg4.patch
+
# Add pulseaudio backend
patch -p1 -i ../0001-Pulseaudio-backend.patch
@@ -45,7 +50,7 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
- ./configure --prefix=/usr --without-rcc \
+ ./configure --prefix=/usr --without-rcc --with-pulse \
--with-alsa --with-oss --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \
--with-sndfile --with-modplug --with-ffmpeg --with-speex \
diff --git a/moc-ffmpeg4.patch b/moc-ffmpeg4.patch
new file mode 100644
index 000000000000..c1e43a7c2f3e
--- /dev/null
+++ b/moc-ffmpeg4.patch
@@ -0,0 +1,33 @@
+Index: decoder_plugins/ffmpeg/ffmpeg.c
+===================================================================
+--- decoder_plugins/ffmpeg/ffmpeg.c (revisiĆ³n: 2963)
++++ decoder_plugins/ffmpeg/ffmpeg.c (copia de trabajo)
+@@ -697,7 +697,7 @@
+ * FFmpeg/LibAV in use. For some versions this will be caught in
+ * *_find_stream_info() above and misreported as an unfound codec
+ * parameters error. */
+- if (data->codec->capabilities & CODEC_CAP_EXPERIMENTAL) {
++ if (data->codec->capabilities & AV_CODEC_CAP_EXPERIMENTAL) {
+ decoder_error (&data->error, ERROR_FATAL, 0,
+ "The codec is experimental and may damage MOC: %s",
+ data->codec->name);
+@@ -705,8 +705,8 @@
+ }
+
+ set_downmixing (data);
+- if (data->codec->capabilities & CODEC_CAP_TRUNCATED)
+- data->enc->flags |= CODEC_FLAG_TRUNCATED;
++ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
++ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
+
+ if (avcodec_open2 (data->enc, data->codec, NULL) < 0)
+ {
+@@ -725,7 +725,7 @@
+
+ data->sample_width = sfmt_Bps (data->fmt);
+
+- if (data->codec->capabilities & CODEC_CAP_DELAY)
++ if (data->codec->capabilities & AV_CODEC_CAP_DELAY)
+ data->delay = true;
+ data->seek_broken = is_seek_broken (data);
+ data->timing_broken = is_timing_broken (data->ic);