summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrElendig2015-06-08 12:07:53 +0200
committerMrElendig2015-06-08 12:08:36 +0200
commitfc40d28f9151ac6cf7261990fdaec53560c06395 (patch)
treeeae5779dc76a3e87e56b4bffcce1f43b098e7363
downloadaur-fc40d28f9151ac6cf7261990fdaec53560c06395.tar.gz
No history for you since aur is stupid
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD47
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0396d0f1823
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = moc-svn
+ pkgdesc = A powerful & easy to use console audio player
+ pkgver = 2758
+ pkgrel = 1
+ url = http://moc.daper.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = speex
+ makedepends = ffmpeg
+ makedepends = taglib
+ makedepends = libmpcdec
+ makedepends = wavpack
+ makedepends = libmodplug
+ makedepends = subversion
+ makedepends = sidplay2
+ makedepends = faad2
+ depends = libmad
+ depends = libid3tag
+ depends = jack
+ depends = curl
+ depends = libltdl
+ depends = file
+ optdepends = speex: for using the speex plugin
+ optdepends = ffmpeg: for using the ffmpeg plugin
+ optdepends = taglib: for using the musepack plugin
+ optdepends = libmpcdec: for using the musepack plugin
+ optdepends = wavpack: for using the wavpack plugin
+ optdepends = libmodplug: for using the modplug plugin
+ optdepends = sidplay2: for playing c64 sid files
+ optdepends = faad2: for use the aac plugin
+ provides = moc
+ conflicts = moc
+ options = !libtool
+ source = moc::svn://daper.net/moc/trunk
+ sha1sums = SKIP
+
+pkgname = moc-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ed26a4aa7a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+#Maintainer: Øyvind 'MrElendig' Heggstad <mrelendig@har-ikkje.net>
+#Contributor: jsteel <mail at jsteel dot org>
+
+pkgname=moc-svn
+pkgver=2758
+pkgrel=1
+pkgdesc='A powerful & easy to use console audio player'
+url="http://moc.daper.net"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
+source=('moc::svn://daper.net/moc/trunk')
+sha1sums=('SKIP')
+makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack'
+ 'libmodplug' 'subversion' 'sidplay2' 'faad2')
+optdepends=('speex: for using the speex plugin'
+ 'ffmpeg: for using the ffmpeg plugin'
+ 'taglib: for using the musepack plugin'
+ 'libmpcdec: for using the musepack plugin'
+ 'wavpack: for using the wavpack plugin'
+ 'libmodplug: for using the modplug plugin'
+ 'sidplay2: for playing c64 sid files'
+ 'faad2: for use the aac plugin')
+conflicts=('moc')
+provides=('moc')
+options=('!libtool')
+
+pkgver() {
+ cd moc
+ svnversion
+}
+
+build() {
+ cd moc
+ autoreconf -f -i -Wall,no-obsolete
+ ./configure --prefix=/usr --without-rcc \
+ --with-alsa --with-jack --with-aac --with-mp3 \
+ --with-musepack --with-vorbis --with-flac --with-wavpack \
+ --with-sndfile --with-modplug --with-ffmpeg --with-speex \
+ --with-samplerate --with-curl --with-sidplay2 --disable-debug
+ make
+}
+
+package() {
+ cd moc
+ make DESTDIR="$pkgdir" install
+}