summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel T. Borelli2016-10-23 19:26:22 -0300
committerDaniel T. Borelli2016-10-23 19:26:22 -0300
commit46e11cfb0d5ac8dfe641103481cc955d84a40fd9 (patch)
tree109d939f24e7c5fb25e338c580652e1f13b4fdbf
parent6dbd57deecc949949328ae84683f81a9b797644c (diff)
downloadaur-46e11cfb0d5ac8dfe641103481cc955d84a40fd9.tar.gz
New rev.: use git+https for source.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5925f8496f95..80a84fcd4e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = moc_notify-git
pkgdesc = Notifier for 'Music On Console' using libnotify.
pkgver = 1.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/daltomi/moc_notify
install = moc_notify-git.install
arch = i686
@@ -14,7 +14,9 @@ pkgbase = moc_notify-git
depends = libnotify
optdepends = moc: Music on Console
source = moc_notify-git.install
+ source = git+https://github.com/daltomi/moc_notify.git#tag=v.1.11
sha1sums = ae6f9be60997863f215d13c0cb0bb8da9bbdd5eb
+ sha1sums = SKIP
pkgname = moc_notify-git
diff --git a/PKGBUILD b/PKGBUILD
index 4f9ff8b2aa01..df3568eb59e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,9 @@
pkgbase=moc_notify-git
pkgname=$pkgbase
pkgver=1.11
-pkgrel=1
+pkgrel=2
+_gitname=moc_notify
+_gittag="v.${pkgver}"
pkgdesc="Notifier for 'Music On Console' using libnotify."
arch=('i686' 'x86_64')
url='https://github.com/daltomi/moc_notify'
@@ -11,28 +13,18 @@ license=('GPL3')
depends=('libnotify')
optdepends=('moc: Music on Console')
makedepends=('git' 'cmake' 'gcc' 'pkg-config')
-_gitroot=$url.git
-_gitname=moc_notify
-
install=moc_notify-git.install
-source=('moc_notify-git.install')
-sha1sums=('ae6f9be60997863f215d13c0cb0bb8da9bbdd5eb')
+source=("moc_notify-git.install" "git+${url}.git#tag=$_gittag")
+sha1sums=('ae6f9be60997863f215d13c0cb0bb8da9bbdd5eb' 'SKIP')
-prepare() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
- git clone "$_gitroot" --branch "v.$pkgver"
-}
build() {
- src_git=$srcdir/$_gitname/
- msg "Starting build..."
- cd $src_git/
- cmake -DCMAKE_BUILD_TYPE="release" . && make
+ cd $_gitname
+ cmake -DCMAKE_BUILD_TYPE=Release . && make
}
package() {
- install -Dm755 "$srcdir/$_gitname/moc_notify" "$pkgdir/usr/bin/moc_notify"
+ install -Dm755 "$_gitname/moc_notify" "$pkgdir/usr/bin/moc_notify"
install -m755 -d "$pkgdir/usr/share/moc_notify"
- install -Dm755 "$srcdir/$_gitname/scripts/onsongchange.sh" "$pkgdir/usr/share/moc_notify/"
+ install -Dm755 "$_gitname/scripts/onsongchange.sh" "$pkgdir/usr/share/moc_notify/"
}