summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel T. Borelli2015-12-23 19:41:21 -0300
committerDaniel T. Borelli2015-12-23 19:41:21 -0300
commit6907b046e927b7c6908bbacefba983eedb74fe08 (patch)
treeaebc14164de968717b8a1c8892ac9b7023fb096e
parent094e3c0cf63d58d05e1be965ab35f11e67452778 (diff)
downloadaur-6907b046e927b7c6908bbacefba983eedb74fe08.tar.gz
Copy onsongchange.sh
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
-rw-r--r--moc_notify-git.install12
3 files changed, 23 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d32875bade18..ed554dad28cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = moc_notify-git
pkgdesc = Notifier for 'Music On Console' using libnotify.
pkgver = 0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/daltomi/moc_notify
+ install = moc_notify-git.install
arch = i686
arch = x86_64
license = GPL3
@@ -11,6 +12,8 @@ pkgbase = moc_notify-git
depends = gtk2
depends = libnotify
depends = moc
+ source = moc_notify-git.install
+ sha1sums = ae6f9be60997863f215d13c0cb0bb8da9bbdd5eb
pkgname = moc_notify-git
diff --git a/PKGBUILD b/PKGBUILD
index ddda32a11c9b..745cbde072a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=moc_notify-git
pkgname=$pkgbase
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Notifier for 'Music On Console' using libnotify."
arch=('i686' 'x86_64')
url='https://github.com/daltomi/moc_notify'
@@ -13,6 +13,10 @@ makedepends=('git' 'cmake')
_gitroot=$url.git
_gitname=moc_notify
+install=moc_notify-git.install
+source=('moc_notify-git.install')
+sha1sums=('ae6f9be60997863f215d13c0cb0bb8da9bbdd5eb')
+
prepare() {
cd "$srcdir"
msg "Connecting to GIT server...."
@@ -28,4 +32,6 @@ build() {
package() {
install -Dm755 "$srcdir/$_gitname/moc_notify" "$pkgdir/usr/bin/moc_notify"
+ install -m755 -d "$pkgdir/usr/share/moc_notify"
+ install -Dm755 "$srcdir/$_gitname/onsongchange.sh" "$pkgdir/usr/share/moc_notify/"
}
diff --git a/moc_notify-git.install b/moc_notify-git.install
new file mode 100644
index 000000000000..aaf1b92f5803
--- /dev/null
+++ b/moc_notify-git.install
@@ -0,0 +1,12 @@
+post_install () {
+ echo
+ echo "Please see /usr/share/moc_notify"
+}
+
+
+post_upgrade() {
+ post_install
+}
+
+
+