summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel T. Borelli2015-12-22 21:03:27 -0300
committerDaniel T. Borelli2015-12-22 21:03:27 -0300
commitc38c3891e6abc020d5af87d40cfa40d599bfc3a0 (patch)
treeeb370db076046e05c64c819a0e645547a3201cb0
downloadaur-c38c3891e6abc020d5af87d40cfa40d599bfc3a0.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82fc0d872527
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = moc_notify-git
+ pkgdesc = Notifier for 'Music On Console' using libnotify.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/daltomi/moc_notify
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = gtk2
+ depends = libnotify
+ depends = moc
+
+pkgname = moc_notify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..371920999d3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Daniel T. Borelli < daltomi at aol >
+
+pkgbase=moc_notify-git
+pkgname=$pkgbase
+pkgver=0.1
+pkgrel=1
+pkgdesc="Notifier for 'Music On Console' using libnotify."
+arch=('i686' 'x86_64')
+url='https://github.com/daltomi/moc_notify'
+license=('GPL3')
+depends=('gtk2' 'libnotify' 'moc')
+makedepends=('git' 'cmake')
+_gitroot=$url.git
+_gitname=$pkgbase
+
+prepare() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" --depth=1 --single-branch "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+}
+
+build() {
+ src_git=$srcdir/$_gitname/
+ msg "Starting build..."
+ cd $src_git/
+ cmake -DCMAKE_BUILD_TYPE="release" . && make
+}
+
+package() {
+ install -Dm755 "$srcdir/$_gitname/moc_notify" "$pkgdir/usr/bin/moc_notify"
+}