summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlevinit2017-07-13 07:58:59 +0000
committerlevinit2017-07-13 07:58:59 +0000
commit662016df73dc0356ee0eaf6f0dd7909a577cfb3f (patch)
tree8aae5d27357ea42b07b493eb205be4c4cc673d64
downloadaur-662016df73dc0356ee0eaf6f0dd7909a577cfb3f.tar.gz
try make a aur
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05dc976efa3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mockingbot
+ pkgdesc = a prototyping tool.墨刀/modao
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://modao.cc/downloads
+ arch = _amd64
+ arch = x86_64
+ license = custom
+ depends = gconf
+ source_x86_64 = https://s3.cn-north-1.amazonaws.com.cn/modao/downloads/MockingBot_amd64.deb
+ md5sums_x86_64 = SKIP
+
+pkgname = mockingbot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7afee187824e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: levinit <levinit at outlook>
+
+pkgname=mockingbot
+_pkgname=MockingBot
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="a prototyping tool.墨刀/modao"
+arch=('i686' 'x86_64')
+url="https://modao.cc/downloads"
+license=('custom')
+depends=('gconf')
+
+if [ "$CARCH" = "i686" ]; then
+ arch="_i386"
+fi
+if [ "$CARCH" = "x86_64" ]; then
+ arch="_amd64"
+fi
+
+source_common="https://s3.cn-north-1.amazonaws.com.cn/modao/downloads"
+source_x86_64=("$source_common/$_pkgname$arch.deb")
+source_i686=("$source_common/$_pkgname$arch.deb")
+
+md5sums_i686=('SKIP')
+md5sums_x86_64=('SKIP')
+
+prepare() {
+ echo "extract fils from $_pkgname$arch.deb..."
+ bsdtar -xJf $_pkgname$arch.deb
+}
+
+package() {
+ install -Ddm755 usr
+
+}
+