summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlevinit2017-07-14 08:35:52 +0000
committerlevinit2017-07-14 08:35:52 +0000
commit72d55722b30fc4b11d4f64c92fbf0735450fc1e8 (patch)
treef4d1d87f9967d9d78758ca8a5247986886dc6f57
parent662016df73dc0356ee0eaf6f0dd7909a577cfb3f (diff)
downloadaur-72d55722b30fc4b11d4f64c92fbf0735450fc1e8.tar.gz
fixed error
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05dc976efa3e..54221f09b31a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = mockingbot
- pkgdesc = a prototyping tool.墨刀/modao
+ pkgdesc = A prototyping & collaboration tool.墨刀/modao/MockingBot
pkgver = 0.5.1
pkgrel = 1
url = https://modao.cc/downloads
- arch = _amd64
+ arch = i686
arch = x86_64
license = custom
depends = gconf
+ source_i686 = https://s3.cn-north-1.amazonaws.com.cn/modao/downloads/MockingBot_i386.deb
+ md5sums_i686 = SKIP
source_x86_64 = https://s3.cn-north-1.amazonaws.com.cn/modao/downloads/MockingBot_amd64.deb
md5sums_x86_64 = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7afee187824e..91980c81f657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,24 @@
# Maintainer: levinit <levinit at outlook>
pkgname=mockingbot
-_pkgname=MockingBot
pkgver=0.5.1
pkgrel=1
-pkgdesc="a prototyping tool.墨刀/modao"
+pkgdesc="A prototyping & collaboration tool.墨刀/modao/MockingBot"
arch=('i686' 'x86_64')
url="https://modao.cc/downloads"
license=('custom')
depends=('gconf')
-if [ "$CARCH" = "i686" ]; then
- arch="_i386"
-fi
-if [ "$CARCH" = "x86_64" ]; then
- arch="_amd64"
-fi
-
source_common="https://s3.cn-north-1.amazonaws.com.cn/modao/downloads"
-source_x86_64=("$source_common/$_pkgname$arch.deb")
-source_i686=("$source_common/$_pkgname$arch.deb")
+source_x86_64=("$source_common/MockingBot_amd64.deb")
+source_i686=("$source_common/MockingBot_i386.deb")
md5sums_i686=('SKIP')
md5sums_x86_64=('SKIP')
-prepare() {
- echo "extract fils from $_pkgname$arch.deb..."
- bsdtar -xJf $_pkgname$arch.deb
-}
-
package() {
- install -Ddm755 usr
-
+ tar -xvf data.tar.xz -C ${pkgdir}
+ mv ${pkgdir}/usr/bin/MockingBot ${pkgdir}/usr/bin/mockingbot
+ chmod -R go-w "${pkgdir}"/usr
+ install -dm755 "${pkgdir}/usr/bin"
}
-