summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hunt2015-06-20 13:14:28 +0100
committerJoshua Hunt2015-06-20 13:14:28 +0100
commita3039b2ef7d9e2057124ef36d1dec97eee0c7b1b (patch)
treeef9a3c8ee9d191b996a23bbc0906bd1f2c173458
downloadaur-a3039b2ef7d9e2057124ef36d1dec97eee0c7b1b.tar.gz
Convert package from old AUR and update to 1.10.19
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD21
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b1258ca6171
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mockito
+ pkgdesc = A java mocking framework that lets you write beautiful tests with a clean and simple API
+ pkgver = 1.10.19
+ pkgrel = 1
+ url = https://github.com/mockito/mockito
+ arch = any
+ license = MIT
+ depends = java-runtime
+ noextract = mockito-all-1.10.19.jar
+ source = https://bintray.com/artifact/download/szczepiq/maven/org/mockito/mockito-all/1.10.19/mockito-all-1.10.19.jar
+ source = LICENSE
+ sha256sums = d1a7a7ef14b3db5c0fc3e0a63a81b374b510afe85add9f7984b97911f4c70605
+ sha256sums = c91362ba4ffbea02d2ed5b7104893d56142479ea58068c95eee17925e25372da
+
+pkgname = mockito
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5eb92481fa26
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License
+
+Copyright (c) 2007 Mockito contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bba73aeb837f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Snark1994 <sna rk 1994 at google mail dot com> (no spaces)
+
+pkgname=mockito
+pkgver=1.10.19
+pkgrel=1
+pkgdesc="A java mocking framework that lets you write beautiful tests with a clean and simple API"
+arch=('any')
+url="https://github.com/mockito/mockito"
+license=('MIT')
+depends=('java-runtime')
+source=("https://bintray.com/artifact/download/szczepiq/maven/org/mockito/mockito-all/${pkgver}/mockito-all-${pkgver}.jar" \
+ "LICENSE")
+noextract=("mockito-all-${pkgver}.jar")
+sha256sums=('d1a7a7ef14b3db5c0fc3e0a63a81b374b510afe85add9f7984b97911f4c70605'
+ 'c91362ba4ffbea02d2ed5b7104893d56142479ea58068c95eee17925e25372da')
+
+package() {
+ install -D -m644 "${srcdir}/mockito-all-${pkgver}.jar" "${pkgdir}/usr/share/java/${pkgname}.jar"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+